Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Window's can't be configured after a system restore

The 320gb hard disk of my Sony Vaio crashed, and I asked Sony reinstallation disk, while buying a new Western Digital 500gb hard disk.

Sony told me the reinstallation disks could work, but there would be no actual guarantee thereof.

Now I ran the 6 installation DVDs, and the installer copied all the files to my hard-disk, and rebooted. At the first run, I got the following message Setup is starting the services (may be an approximate translation, the actual message in in French). Then after 3 seconds, an error message saying that Windows couldn't finish the setup, and that it will reboot.

Is it due to the disk size change? Is there a work-around I can use to finish my setup?


  • My previous hard drive: Toshiba MK3265GSX (SATA 2.6 / ATA- 8)
  • New hard drive: WD Scorpio Blue WDBABC5000ANC-ERSN (Serial ATA-300)
share|improve this question

marked as duplicate by studiohack May 28 '12 at 19:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

The size of the disk shouldn't matter. If it did anything, it would cause activation to fail - not something like this. Can you post the actual error message that appears, or the error code? – ChimneyImp May 26 '12 at 18:57
Here's a picture of my error message. It's in French, so translated it says: "Windows could complete the installation. To install Windows on this computer, run the installation program again" (in the MsgBox). And below, the text "The installation program is starting the services" – Gerard Yin May 26 '12 at 20:18
up vote 1 down vote accepted

Try installing Windows again, like the error message says to do. It might be one of those weird, transitory errors that happens.

The "starting services" message sounds like the message that normally appears when Windows boots up, so it probably finished most of the installation, but something just went wrong or didn't get copied.

EDIT: I think this might be the answer to your current problem. It makes perfect sense with the new HDD - try out the answer there.

share|improve this answer
Thanks, I just tried that, and realized that the first time after the installation a different error is in fact returned. Windows just finished configuring the devices, and the next step was : "The installer is applying system parameters", when I received the MsgBox "Windows installer couldn't configure Windows for execution on this computer's hardware". – Gerard Yin May 27 '12 at 15:22
At the next reboot, I activated ntbtlog.txt, and notice that 2 drivers won't load: - Did not load driver \SystemRoot\system32\drivers\vga.sys - Did not load driver \SystemRoot\system32\drivers\NDProxy.sys – Gerard Yin May 27 '12 at 15:26
vga.sys is a video driver, NDProxy is a network driver. Since you can see the screen, vga.sys probably isn't the problem. Can you boot into Safe Mode (hold F8 at Windows boot)? I'm not sure how far along you are in the installation process. If that doesn't work, I might have to tap out - I'm pretty much stumped, I've never seen something like this before with a fresh install. – ChimneyImp May 27 '12 at 17:12
I also ran the Acronys Alignment tool, which didn't detect any misalignment. It was recommended by Western Digital as this is a cloned software. – Gerard Yin May 27 '12 at 17:15
Thanks, I'll try with Safe Mode. If it doesn't work, I'll try installing another complete version of Windows 7 Home Premium instead of this current OEM. Which means I'll also get to give Microsoft another 200 euros for a new product key... – Gerard Yin May 27 '12 at 17:17

Not the answer you're looking for? Browse other questions tagged .