Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ASUS Sabertooth 990FX Motherboard, with an AMD FX8150 processor, and Crossfired (2) Sapphire 6870 1 GB GDDR5 PCI E 2.1 x16 Video Cards. The memory is PNY DDR3 1866 (4) 4 GB sticks for a total of 16 GB of RAM. I had a post up that stated my UEFI BIOS was crashing/freezing when I tried to enter it. I tried a slew of tests and combinations to get it work, and nothing worked, until I switched out the memory with PNY DDR3 1333 same configuration, (4) 4 GB sticks for 16 GB total, and the UEFI BIOS now works.

My question is why? How can the faster RAM make the BIOS crash when the lower works? The MB supports 1866/1600/1333/1066. Now, I did notice that after I have bought everything, on ASUS's website, they have a list of Qualified Vendors List, and PNY is not on there, which I think is crap, but what would that have to do with memory working? I will admit that when it comes to memory, I would be a noob, but isn't memory essential memory? Excluding timing and whatnot. If two different brands had identical settings, wouldn't they be equal? I mean I have bought the memory figuring it would be nice to use the highest the board will allow, and now it appears that I might have to use the near bottom. I am hesitant to try and buy DDR3 1600. That might make it more of a waste of money if it doesn't work.

Is there anyway I can configure the BIOS under the 1333 to run properly under the 1866?

share|improve this question
    
You mention a lot of details, but not the specifics about the RAM modules. For example, the required voltage might be of interest. –  Dennis May 26 '12 at 23:05
    
@Dennis - The MB doesn't state required voltage. But if it helps, the 1866 is 1.65V and the 1333 is 1.5V. And the timing of the 1866 is 9-12-9-27. The 1333 doesn't state it, but I think it is 9-9-9-27. I'll try to look –  Brian May 26 '12 at 23:10
    
@Dennis - I looked on PNYs website, no details on the timing for the 1333. But I do know that the CAS for both is 9 –  Brian May 26 '12 at 23:15
    
The MB doesn't have a required voltage. But if your MB isn't capable of delivering 1.65V to the RAM modules, it would explain why one set of modules works and the other doesn't. To troubleshoot: Try the modules one by one. If one is faulty, only that one will crash your computer. –  Dennis May 26 '12 at 23:25
    
When I got in the BIOS on the 1333, I looked at voltage, it's set to AUTO, but I saw I could set the voltage on any of a dozen or more settings. I could try to check the other 3 for that. However, if I don't try to go into BIOS, the system does boot. Could one or more faulty module allow for system boot? –  Brian May 26 '12 at 23:29
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.