Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ATI Radeon HD 4800 graphic card, when I open CCC I can select many different resolutions. When I open Control Panel > Screen Resolution, I only get few resolutions (1920x1080x, 1280x1024, etc).

Now, the problem is that I get bad fps in Diablo 3 when I choose the recommended resolution: 1920x1080. I want to be able to select 1400x1050 in Diablo 3 (1280x1024 looks really bad), but I can't because it limits itself to what is avialable in Control Panel.

I've tried to edit d3pref.txt, installed PowerStrip (Advanced timing options is greyed out), updating driver (from dell site, tried Generic Non-PnP Monitor and Generic PnP Monitor), 'Hide modes that this monitor cannot display' option is unchecked and no success.

I just want to add a new custom resolution to the screen resolution list in Control Panel, so I can choose lesser and not so bad resolutions in Diablo 3 and other games.

Monitor: DELL S2309W

share|improve this question
This tutorial will help you add custom resolutions to CCC. IIRC, Control Panel will take effects too after done this. – Mengdi Gao May 27 '12 at 8:05
Followed the tutorial. Added 14 00 10 50 00 00 00 00 to Key DALNonStandardModesBCD1, restarted computer and control panel is just showing the old resolutions. – user658091 May 27 '12 at 8:15
I found the solution. I found different drivers from what Device Manager shows, and installed Dell Driver instead of Generic ones, and it worked. In 8 hours I will post the instructions if someone is having my same problem. – user658091 May 27 '12 at 8:30
That solution is my post. If you read carefully, you can see I'm saying exactly what I'm saying here. – user658091 May 27 '12 at 15:42

1 Answer 1

I upgraded to Windows 10 an encountered a problem with my TV's resolution (plugged in as a HDMI monitor): though I could still "set" a custom resolution in NVidia's Control Panel, it would keep the Windows 10 resolution, even after restarting and such, with fully upgraded drivers.

I fixed it by following the advice from here, which says:

Go to the Display Properties > Settings > Advanced > Adapter and check for an option that says something like 'List all modes'.

Basically, go into (Windows) Control Panel, to change the resolution, select the monitor/TV you want to change, click "Advanced Settings" (in Windows 10 and I think Windows 8 too at least), go to the Adapter tab (first one), and click the "List All Modes" button. I scrolled all the way to the bottom of the list that pops up, and my custom resolution that was previously set in the NVidia Control Panel (but currently unused) was there. Select the resolution you want, click "OK", and then click "OK" or "Apply", and it will give you that resolution.

Update: sometimes this doesn't work... after my NVidia driver updated, the custom resolution reverted, and redoing it and restarting my computer didn't fix it - nor did the custom resolution show up in "List All Modes"! The solution to this problem was to simply unplug my TV and plug it back in, and when I went to Control Panel again the custom resolution finally showed up.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.