Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I connect to a network wireless or LAN The laptop does not take the right IP Configuration while the adapters are set to obtain the IP Configuration Automatically, after connecting to the network It take an IP from different range than the one set in DHCP configuration, the obtained IP is 169.254.127.50 and Subnet Mask is 255.255.0.0 which is class B I guess, while it should take IP from the Range 192.168.1.X and subnet mask 255.255.255.0, also I get no Default Get Way and no DNS server.

I cleaned the Windows from viruses and also I found that DHCP Client Service Could not start automatically and when i try to start it manually I get the "Error 5 access denied" message, any way I fixed the DHCP Client service issue using the steps in this link taking in regard Rusty Shack comment, so the service now can start automatically but the IP configuration still the same also I found that the Diagnostic Policy Service has the same DHCP Client issue but I couldn't fix that using the same method i used to Fix DHCP Client Service problem, also I don't Know what other services could configuring the IP Depend on, Is there any way to fix these Issues using a tool or other methods

share|improve this question
    
@Moab: no, an autoconfig address doesn't necessarily mean that the adapter drive or config is corrupt. It might just mean that no DHCP server responded to the request. (And if Windows can't see a network adapter at all, it doesn't acquire any addresses.) –  Harry Johnston May 28 '12 at 3:00
    
Thanks Harry... –  Moab May 29 '12 at 21:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.