Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I made an image of my entire C:\ drive using EaseUS Todo Backup Free, before formatting and setting up a new Windows (7 Professional) system. I can mount that image read-only in Todo Backup and copy over a few files which I need, everything fine up to here.

Problem is, I need to access some of the files in C:\Users\dvrcoder files on that image. I can't access them since they are owned by the "old" dvrcoder user (whose SID was different than the new one on the new Windows system). I also can't obtain ownership of the files, because the mounted backup image is read-only.

Can I somehow "connect" to the drive using a different SID? Or mount it in a different way? Or make a new user with a SID corresponding to the old one? Or access the files in some other way?

share|improve this question
    
Have you tried taking ownership of the folder using the security tab of properties of that folder> –  Moab May 27 '12 at 22:33

2 Answers 2

Have you tried taking ownership of the folder using the security tab in properties of that folder?

Easeus Note: We suggest you mount the image file with the same Windows user which you used to create the image file. This can ensure you have full access permission after the driver mounted.

share|improve this answer
    
@Easeus Note: That's exactly what I'm trying to do, problem is, said user doesn't exist anymore because my new Windows system has different SIDs from the old system... Can I make a Windows user with a custom SID for that purpose? –  dvrcoder May 27 '12 at 23:10
    
@taking ownership: doesn't work, whether I open Explorer as Admin or not. My interpretation was that I couldn't write new permissions to the file because the image is read-only. –  dvrcoder May 27 '12 at 23:11
    
Ok, installed Easeus, did not see any option to mount images with write permissions, evidently free version has limitations. –  Moab May 29 '12 at 21:13

You can copy the folder in question to your local disk using robocopy.

Start an administrative command line window by typing cmd into the Start Menu and pressing Control-Shift-ENTER.

Assuming the volume is mounted as drive E, and that you are running as administrator, type the following command:

robocopy /e /b e:\users\dvrcoder c:\copy-of-dvrcoder

The /b option tells robocopy to use backup privilege to override the security permissions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.