Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I managed to briefly get this working before, but I was messing around with creating these via the command line and was deleting and creating them and now it's stopped working. This is what I've tried so far:

  1. Delete the Host-only network and re-add it.

  2. Delete the Host-only network and re-add it and restart virtual box.

  3. Delete the Adapter from the VM and re-add it.

  4. Restore the VM to a point before this adapter and add it.

  5. Restart OSX.

  6. Create a Host-only network that has not existed before vboxnet3 and try to use that.

My host system is and my guest system is . When I go into Ubuntu it tries to connect for a while but then just says wired network is disconnected.

enter image description here

Host system ifconfig:

vboxnet0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        ether 0a:00:27:00:00:00 
        inet 192.168.56.1 netmask 0xffffff00 broadcast 192.168.56.255

Guest system ifconfig:

eth1      Link encap:Ethernet  HWaddr 08:00:27:82:38:af  
          inet6 addr: fe80::a00:27ff:fe82:38af/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:188 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6901 (6.9 KB)  TX bytes:42262 (42.2 KB)

What have I done wrong?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I hadn't configured a DHCP server for the Host-only net, once I had done that it worked fine. I'm not entirely sure why this was working for me once despite this, maybe I had managed to do it somehow.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.