Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ubuntu computer.

Each time I open the console there is some animal in ascii art and a quote.

How can I uninstall this and get a normal command line?

All accounts have this, so it is global on this machine.

Example:

 ________________________________________
( Celebrate Hannibal Day this year. Take )
( an elephant to lunch.                  )
 ----------------------------------------
       o   ,__,
        o  (oo)____
           (__)    )\
              ||--|| *
share|improve this question
    
I'm pretty sure this does not ship with Ubuntu by default ;) So what did you do to that poor computer? Installed any custom MOTD? What's the content of /etc/update-motd.d/? Edited your shell's profile or configuration files? –  slhck May 27 '12 at 20:04
    
I did not say it shipped. Maybe someone installed it. I hope I can get an answer. sudo ls /etc/update-motd.d/ 00-header 20-cpu-checker 91-release-upgrade 99-footer 10-help-text 90-updates-available 98-reboot-required –  J. Jason May 27 '12 at 20:06

2 Answers 2

up vote 4 down vote accepted

Check the contents of Bash's system-wide configuration file:

gksudo gedit /etc/bash.bashrc &

See if there's a line with:

/usr/games/fortune

Comment it out and save:

#/usr/games/fortune

Then try to see if the message has gone away by restarting terminal.


The package responsible should be called fortune, so you can generally remove it by typing:

sudo apt-get remove fortune

On Linux Mint, the offending packages are removed like this:

sudo apt-get remove fortune-mod fortunes-husse fortunes-min

Of course, delete the line in bash.bashrc referring to those packages.

share|improve this answer
    
Thank you very much! Very glad this is gone. –  J. Jason May 27 '12 at 20:32
    
I appended your answer to mine, so the solution is in the right place :) Mind the difference between Linux Mint and Ubuntu though, that explains the difference in packages. –  slhck May 27 '12 at 20:36
    
s/Uncomment/Comment/ –  Heptite Jul 16 '13 at 18:18

Also on Mint, Got to Menu > Preferences > Desktop Settings > Terminal : Uncheck 'Show fortune cookies'.

Im using Mint 13 (Maya) mate edition.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.