Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've changed my computer name in these places:

/etc/hostname
/etc/hosts

But when I try and connect Synergy with the new name, in the log it's still attempting to connect with the old name. I can also only access the computer from other computers (it's running lamp) with it's old hostname and not the new one.

What am I missing? I've done a full reboot.

share|improve this question
    
How have you got it configured in synergy? –  Paul May 28 '12 at 9:12
    
My Ubuntu machine is a Synergy client (not server), I can't see anywhere I would set the computer name in the client settings. On my Synergy server if I set it to expect the new name, it will not connect. Set it to the old name and it connects straight away. –  Anonymous May 28 '12 at 9:14
    
As user root, try this: find /etc -type f -exec grep OLDHOSTNAME {} /dev/null \; (and, yes, there's a backslash before that semi-colon in the find command). This should show you any files under /etc that still contain the old hostname. –  Fran May 28 '12 at 22:10
    
Hi Fran, it didn't find anything with my old hostname. –  Anonymous May 29 '12 at 9:24
    
QuickSynergy on Mac/Linux or NQuickSynergy on Windows supposedly takes all the pain out of using Synergy. –  harrymc Jun 1 '12 at 14:52

6 Answers 6

Try connecting to the Synergy Server with this commandline in Ubuntu:

synergyc -f --name <my-new-hostname> <servername>


If you do not run your own internal DNS server then you will need to specify the new hostname for your Ubuntu box on each computer in the network (usually the hosts file).

Flush the arp and dns cache and modify the hosts file on the SERVER to include an entry for the CLIENT machine and try again.

share|improve this answer
    
That works great, but still doesn't explain why other PC's on the network can't resolve my new hostname. –  Anonymous May 30 '12 at 8:03
    
Did you attempt to flush the arp and dns cache and add an entry in the hosts file on the SERVER for the CLIENT machine? –  Jeremy W Jun 5 '12 at 15:28

Try looking out for your user's synergy.conf in /home/yourusername/.config/synergy/ and editing it to suit your new hostname's SCREEN-NAME... mine kept itself unmodified even between uninstalls.... check in/with:

gedit ~/.config/synergy/synergy.conf

BTW: That hostname vs screenname naming thing is not consistent enough in the GUIs, (Quicksynergy gave me a hint thou) which can get very confusing.

share|improve this answer

I did the following which fixed it.

sudo apt-get remove --purge synergy

or

sudo dpkg -r synergy

then

sudo rm ~/.config/Synergy (the synergy.conf file in this folder was causing the host name issue so I deleted the whole folder and started over)

then

sudo dpkg -i synergy-1.4.12-Linux-i686.deb

share|improve this answer

open a terminal then go to root and do the command enter image description here

contents of the file is usually

enter image description here

The second line is usually still contains the old computer name. please change that name to name a replacement, we have just input. Save, and then exit from gedit.

Next please exit of the root. And try to return to the root by typing sudo su.

share|improve this answer
    
Hi there, thanks but like I said in my question, I've already changed the name there and in /etc/hostname. Being logged in as the root user didn't make a difference. Thanks anyway. –  Anonymous May 28 '12 at 10:01
6  
How come you have HTML tags in your hosts file? –  Adrian Ratnapala May 28 '12 at 10:31

Have you tried to clear the cache or reset the default setting in Synergy? I guess it might cached your old hostname and ip down.

Do you sure that the host name is changed normally in the host machine(uname -n)? And if it does changed successfully, then it might be your client's problem, to clear the cache like what I said above may helps.

If you got that the host name is still the old one, you might need to ensure that /etc/hostname and /etc/hosts is not automatically restored.

share|improve this answer
    
Tried completely removing and reinstalling synergy. uname -n shows my new computer name. /etc/hostname and /etc/hosts are not being automatically restored. Thanks anyway. –  Anonymous May 29 '12 at 9:25
    
@Anonymous It's really strange. I'm sorry that I don't have further idea about that. –  Shou Ya May 29 '12 at 13:53

Try this out.

First, open your terminal in your ubuntu,

Than Input the following command and type :

gksudo gedit /etc/hostname

than hit ENTER,

After that, input administrator password and click "OK" button,

Than the hostname will show up, and rename it,

When you done, save and restart your system.

share|improve this answer
    
Hi there, as I've said in my question (and in response to some answers) I've already tried this without any luck. Thanks. –  Anonymous Jun 4 '12 at 7:56
    
well it can be done sucsessfully in my pc... let me do some reserch first... i'll ask my friend if they know somthing that i don't know... –  Kelvin Maurits Jun 4 '12 at 16:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.