Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having AP1 in our home. I've recently bought AP2 to expand our Wi-Fi coverage. Now AP1 and AP2 is about 13 metres (43 feet) and 4 walls away from each other.

Let's say I connect to AP1 then walk over to AP2. At this point I'm still being connected to AP1 even though its signal is super-weak and the signal of AP2 hits through the roof. I only get auto-connected to AP2 if I walk further away from AP1 so its signal completely dies.

I'd expect to get auto-connected to whichever AP has the strongest signal level wherever I am. This is apparently not the case. In many ways the current situation is worse than before setting up AP2.

I've tried to set up same and different channels and Wi-Fi modes on these APs without success.

Is there any way to improve the switchover?

AP1: ASUS WL500GPv2 (running OpenWrt)
AP2: TP-LINK TL-WA701ND (operating in access point mode using a different SSID)
Test device 1: Samsung Galaxy S2
Test device 2: Apple iPad 2

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

For roaming to work, the two APs should have the same SSID and security settings (same encryption type, PSK passphrase, etc.), but be on different, non-overlapping channels.

They should also both connect to the same bridged Ethernet network (that is, if AP1 is doing NAT and DHCP service, then AP2 should be just a bridge, so that clients of AP2's wireless service still use AP1's NAT and DHCP services). You don't want different subnets and NAT gateways causing problems on your roaming network.

Even when you get everything set up correctly, you might find that some clients are less prone to roam than others. The IEEE 802.11 standard doesn't specify a roaming algorithm; it leaves that up to the client implementors as an implementation detail. Some 802.11 clients have better roaming algorithms than others.

share|improve this answer
    
Sorry for accepting your answer so lately. In the meantime I set up the same-SSID configuration that you suggested and experienced the same kind of switchover problems. I concluded that my best bet is to only use a single AP and extend its range as much as possible rather than using multiple APs. Also blogged on this issue at monda.hu/blog/2012/07/13/… –  László Monda Nov 27 '12 at 0:39
add comment

You've not got it set up for proper roaming by the sound of it. If the two APs are on the same SSID and are correctly set up, the devices will choose the strongest.

Devices won't seamlessly range between networks with different SSIDs because that usually gives you a new IP address which will drop all your TCP/IP streams.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.