Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I login as root in fedora after the fedora boots?

When signing in by specifying username : root and password : xxxxxxxx fedora says unsuccessful login attempt. This is the same password I specify when using sudo command.

I always have to login as an under privileged user on my own machine by specifying the username I created while installing fedora, or just before fedora prepares working environment for the first time.

I want to mention that both the passwords for root and non-root are same. Can this cause a problem?

I am using fedora-16 Gnome.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

To login via the GUI screen you need to enable root login.
See: Enable root user in Gnome for Fedora 14?

Also, the password you type when using sudo is the password of your own user, not root. You can change the root password using sudo passwd.

share|improve this answer
    
is there a difference between su and sudo ? –  Suhail Gupta May 28 '12 at 12:24
3  
@suhail-gupta: Yes su and sudo are completely different things. su is used to log on as a different user and requires the knowledge of that user's password. sudo allows specific users to execute ("do") commands with the privileges of another user. Sudo is normally configured not to require knowledge of that other user's password. Sudo also limits the commands that can be executed to the ones configured. "Switching User" (su) gives you full access. There are more differences such as that the commands executed using sudo also usually logged. –  Bram May 28 '12 at 13:17
2  
su stands for "switch user" while sudo stands for "super user do". su without operand assumes that you want to switch to root user. –  dag729 May 28 '12 at 13:17

From this answer:

To permanently enable root login to gnome under Debian, edit the /etc/gdm/gdm.conf file.
In the [security] section of the file, add the following line:
AllowRoot=True

share|improve this answer
    
-1, you probably just copied this answer and didn't even bother to fix the formatting. Next time, please cite your sources — and if the question seems to be a duplicate of another one, please don't answer it. –  slhck May 28 '12 at 13:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.