Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been setting up my computer for work, which runs Linux Ubuntu, and we use a lot of programs etc. so it has taken a day or two to get it all ready.

I was going to have a dual boot with a Windows 7 partition as well. I installed Windows 7 and set that up. Now, when I boot up the system, I can't choose Ubuntu anymore.

Anyone know a quick fix, or do I have to start all over again?

Okay have tried 2 guides now... none worked, can someone give me step by step, info i think you need:

Linux = ubuntu 12.04 windows 7 Partition with linux = sda1

share|improve this question

migrated from May 28 '12 at 14:31

This question came from our site for professional and enthusiast programmers.

up vote 4 down vote accepted

You need to reinstall GRUB from the Linux LiveCD. You can read more about it, for example, here:

And yes, it's not a programming related question, it's about system administration.

share|improve this answer

It's the windows installer that silently wiped your first disc's MBR. This is where GRUB loader was installed before, now it contains the MS NTLDR loader instead.

As previously said by other answers you have to reinstall GRUB starting from a Linux rescure CD, ubuntu or any other linux CD/DVD capable of mounting your disc partitions.

The procedure depends on the rescue disc, but generally it's:

  1. start the linux rescue disc
  2. mount your / partition
  3. chroot your new / filesystem
  4. mount /proc, /sys and /dev virtual filesystems
  5. mount /boot (if it's a dedicated FS)
  6. reinstall GRUB on your starting HDD's MBR
  7. umount anything
  8. reboot the system without the rescue disc
  9. choose "linux" from the list of options :-) (joking)
  10. uninstall windows :-) :-) :-) (joking again, don't do it if you not need to!)
share|improve this answer
Think i just screwed up even more.. did mount my linux to /media/root and then i did chroot /media/root . Now it cant run fdisk -l anymore – Anders Metnik May 28 '12 at 14:50

You should be able to reinstall the boot loader from an install/rescue Ubuntu disk.

share|improve this answer

I have conceived a solution, hope it helps.

  1. Install wingrub (grub for windows, hope that works for win 7), which allows multi booting on windows. Be sure to install it in C:\
  2. Edit your wingrub conf to add your ubuntu booting lines to its boot options. Get the lines which you should add to the conf file in the following way:
    1. Boot from your linux rescue disk.
    2. Mount your linux /.
    3. Copy the lines which boots your ubuntu from /etc/grub.conf
    4. Add these lines to your wingrub conf.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .