Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

tl:dr;

(for those of you who think scrolling past screenshots takes too much time):
How do I configure Mass Effect to use my NVidia graphics card?

My problem:

I have an ASUS N53SN which, except for the NVidia GeForce 550M card also has an adapter called "Intel(R) HD Graphics Family" in device manager. As I understand it, this adapter is somehow built-in in the motherboard, but I might be wrong on this point.

I just installed Mass Effect (yes, the first game in the series) and I was taken to the configuration utility to set my graphics (and other) settings. Well there, I noticed I could not choose my NVidia card:

Mass Effect Configuration Utility does not give any option for the NVidia card

I went into the NVidia control panel, and checked there what setting I had for choosing graphics cards. I made sure the global setting was to use the NVidia card:

NVidia Control Panel global settings: always use the NVidia card

I also added application specific rules for all programs in C:\Program Files (x86)\Mass Effect and C:\Program Files (x86)\Mass Effect\Binaries, that said "use the NVidia card":

enter image description here

After entering these settings, I let the configuration utility rescan my hardware. However, none of this has helped - the first screenshot is still accurate.

How do I let the configuration utility know that I have an NVidia GeForce card, so I can choose appropriate graphics settings?

share|improve this question
    
Usually with dual cards like this, you can force your system to switch to the discrete graphics - could you do that and try to run the config? Or alternatively, in the "Manage 3D Settings", add the Mass Effect configuration utility into the list and set it to use nvidia. That way, when you run the config, it should switch graphics, then the config utility will see it. –  Paul May 28 '12 at 23:50
    
@Paul: As you can see (in the third screenshot), that is exactly what I have done. It didn't work. –  Tomas Lycken May 29 '12 at 1:00

1 Answer 1

up vote 1 down vote accepted

According to NVidia, that GPU isn't active until you need it, which means that while you are in Windows using the Mass Effect utility to decide on the graphic options, you can't see that video card. I mean, you have already experienced this, but the reason why is because you can't activate the GPU manually.

Now, what you have done, when you went into the NVidia control panel, manage 3d settings, programs tab, is you told your NVidia control panel to always use the NVidia GPU when you play Mass Effect (just in case it would have decided to use the IGP for whatever reason). Instead of letting the chipset decide, that is.

Once you start Mass Effect, you can go to the options menu and change the graphic settings from there. Some of the setting changes might require a restart, but at least the game will be using the NVidia chipset at that point.

share|improve this answer
    
Thanks! That clears things out a little. –  Tomas Lycken May 29 '12 at 1:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.