Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem with Internet Connection Sharing on a laptop running Vista Business. This laptop is connected to the internet via the ethernet port, which goes to an ADSL modem. it is automatically assigned the IP address 192.168.1.50, and the modem/gateway is 192.168.1.1

My friends laptop is running Vista Home. Previously, I would create an ad hoc wireless network, enable ICS, and everything would be perfect. My friend would have internet access via this.

However, something has now mysteriously broken. If I enable ICS on the wireless connection, it resets my Local Area Connection, assigning it the manual IP address of 192.168.0.1, which means my connection to the internet is destroyed. Both wireless adapters on each network are assigned auto configuration addresses, in the 168. range.

They can see each other fine, but my friends laptop cannot access the internet via mine, even after I have restored the Local Area Connection settings.

I understand the computer with ICS enabled must have the IP of 192.168.0.1, but previously, before whatever went wrong, my wireless adapter would be 192.168.0.1 and my friends computer would get an IP via DHCP.

I have also tried setting static IP address and making a bridge, none of which works. How can I fix this problem, and prevent enabling ICS from touching my Local Area Connection?

Both machines have no firewall, have appropriate settings etc...

share|improve this question

2 Answers 2

this is perfectly normal. to enable ICS you'll need 2 NICs in your computer (or 1 modem + 1 NIC if on dial up).

NIC #1 (192.168.1.50) connects to your router (the internet) via DHCP, NIC #2 is on a static address (IP 192.168.0.1/Subnet 255.255.255.0) and the internet connection on NIC #1 is shared. now another computer can connect to NIC #2 (either static with IP 192.168.0.21/Subnet 255.255.255.0/Gateway & DNS 192.168.0.1 or via DHCP).

if NIC #2 is a wireless adapter it must support AP mode in order to get it working. so make sure access point mode is enabled for your wireless adapter.

share|improve this answer
    
Nooooo. The problem is that NIC 2 should be the ICS enabled NIC with the static IP of 192.168.0.1, but instead, enabling ICS overwrites the settings for NIC 1, thereby destroying the internet connection. This is not notmal behaviour, and was not happening previously. –  Bill Grey Sep 18 '09 at 0:30
    
when you enable ICS, you'll be asked for a connection to share, there you'll have to select NIC #2, then NIC #1 will be configured for static address. –  Molly7244 Sep 18 '09 at 0:38
    
Yes, I know. The problem is that sharing my internet connection has resulted in the internet connection itself being configured in such a way as to lose internet. This is abnormal behavior, and has only started happening recently. –  Bill Grey Sep 18 '09 at 1:47
    
the key here is AP mode, did you change the controller settings recently? it must be configured as access point. –  Molly7244 Sep 18 '09 at 2:15
    
My driver does not have any option to enable or set AP mode, and I did not previously set it. No driver settings have been changed at all, and I can set up an adhoc network without a problem. –  Bill Grey Sep 18 '09 at 15:11

I suggest reinstalling the NICs drivers, or maybe a system restore can solve this.

share|improve this answer
    
Already tried, and no, a system restored changed nothing... –  Bill Grey Sep 18 '09 at 16:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.