Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a definitive answer for how to stop intermittent "skips" or pauses while playing music from iTunes to an airport express connected to my home stereo? When I read other forums I see a wealth of posts that say "I did XYZ and it's fixed" followed by "I tried XYZ and it didn't work."

This does not appear to be signal strength related. The green light on the Airport Express does not turn to yellow/orange. Other wireless devices have no trouble connecting at the same or greater distances from the wireless router.

share|improve this question

10 Answers 10

I say it is a hardware issue. I had an old AX (802.11G) that was working fine for several years but eventually started to skip. It was not only music that skipped but the general network stability was bad. I then replaced my main router (Linksys 54GS) and the problems disappeared and the AX skipping got better but not as good (=non existent) as when it was new. With time, the music playback got worse again (while the general network stability was good). No matter what I did, (resetting the AX, changing settings etc) the music skipped skipped skipped!

I finally replaced it with a new (802.11N) AX and now everything is fine (it is combined with a Asus RT-66AC and a Ubiquity Nanostation). You might notice that the AX gets surprisingly hot during playback. After enough hot-cold (expand/contract) cycles the material fatigue sets in and I guess soldering points break, radio transmitter/receiver get slightly out of frequence and other similar degrading of the electronics all help to make the unit unreliable.

share|improve this answer
    
Worth noting is that some file(type)s seems to be more stable to play than others. My guess is that the computing requirements varies depending on the compression type used (e.g., mp3 cbr, mp3 vbr, aac, lossless compression etc) and on hardware that is about to fail the CPU must struggle harder with tasks other than decompressing the music stream. Hence skipping. –  user23122 Apr 30 at 14:34

As soon as I started storing music on my timecapsule and streaming through itunes to airport express, the stream would stop after a couple songs. When playing music on my hard drive there was no problem, just when streaming from the remote hard drive. After searching and experimenting I found no solutions. I downloaded a free trial of Airfoil and realized that the stream was uninterrupted whether from the TC or local.

I know it's not a free solution but its not that expensive, can be used to stream any program and its only $20.

share|improve this answer

Ok Here is something weird. The solutions: at least for my MBP 2,53 is to reset the PRAM and NVRAM. Without any changes to my network, my Airport express, streaming works fine from the IPhone. Therefor it has to be an issue with my Macbook P. After the reset everything works it the way it's supposed to.

share|improve this answer

+1 to quack quixote's point.

If you have a router that supports using 5Ghz instead of the much more common (and commonly crowded) 2.4Ghz, you might get a more reliable signal. Even with "strong" signal strength (and a green indicator light) I find that AirTunes is finicky. You have to have the Airport closer to your router than most other devices to prevent skips.

share|improve this answer

I have a related problem that may or may not help you. I too experience the same sudden pause in iTunes playback to music, podcasts, and videos. My iTunes catalog is on a Time Machine connected via ethernet LAN connection to my MacBook Pro. Following one of the instructions from the linked cnet article fixed the problem completely.

quote from the article: “Turn router (including AirPort Base Stations) off, then on [Useful for: repeated dropouts, no Internet access] In some cases, turning a wireless router (including AirPort Base Stations) off, then back on -- usually by unplugging then re-connecting to power -- re-establishes proper operation in the event of a dropout. This is a method of recovery rather than obviation, however.”

I did a soft reboot on the Time Machine and reconnected with it. I no longer have pauses during playback,

Hope this helps.

share|improve this answer

Unfortunately, I agree with quack quixote, that this is an almost unanswerable question, but it's not an unsolvable one. When you try the right combination of things it will work better. But there are many variables. First of all, most WiFi 802.11 devices have bugs and incompatibilities of some sort. I've found the Apple devices to be very very good, but nothing, including expensive Cisco APs are perfect. The standard is just too complicated.

Things to check -- is your signal sometimes being jammed by nearby cordless phones or microwave ovens, or by other WiFi networks?

Are you running iTunes on a Mac or something else? I have seen drop-outs in connections between some WiFi APs or stations and Apple gear. I expect the WiFi to work really well between two Apple devices.

Do you know that it never skips when playing songs locally (not over a network)?

share|improve this answer

I was having this problem and seem to have stumbling on a solution that so far is working. I have two of the older 802.11 b/g AEs and a newer 802.11 n AE. All of them were having intermittent drops when using Air Tunes. Each was configured to sync to a time server automatically. When I checked the logs, the units were synching every 10 minutes or so. I turned this feature off and have had no issues since doing so.

share|improve this answer

There is no "definitive" answer for your issue, because the symptoms you are experiencing can have a wide range of causes and solutions. The link posted by Systech provides a good overview of tweaks that may help, but nobody can point to a single solution on that page and tell you "do that one" because nobody here has full access to your environment. The best we can do is speculate, and help point you to things to try.

If you want an absolute solution to a wireless problem, there's only one: replace the wireless connection with a wired one, and disable all wireless devices. That will guarantee an end to your wireless problems.

Of course, if the intermittent skips are not caused by a wireless problem, even that solution may not help.

share|improve this answer

I was having the same problem, went to this website followed the instructions and now it works fine

share|improve this answer
2  
Which of the many instructions on the page did you try? –  Alex B Sep 21 '09 at 16:03

It's wireless. If you're out of the Signal Range - it's going to skip - regardless of any other changes.

Get another AirPort Express to bridge the distance of your current setup.

share|improve this answer
    
This does not appear to be signal strength related. See added info to question. –  Alex B Sep 21 '09 at 16:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.