Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows XP when an application that doesn't currently have the focus wants to attract the user's attention its Taskbar item blinks. Often it blinks 3 times and then stops, which is fine. However, sometimes it just keeps blinking forever. An example of that is Firefox with a new JavaScript confirmation dialog. This is really annoying if I don't want to switch to that application just now - I basically cannot focus on anything else because of this stupid blinking thing distracting me! How do I force all apps to blink only 3 times (or X times) and then stop?

share|improve this question
    
Oh I remember that horrible thing, don't recall seeing it on Vista, and no problems on Win7. –  Nick Josevski Sep 18 '09 at 1:02

2 Answers 2

You can accomplish this with Tweak UI, part of Microsoft's PowerToys for Windows XP.

Download and install Tweak UI (or click here for the 64-bit version), and fire it up. Expand the General section, and click on Focus. Check the "Prevent applications from stealing focus" checkbox, and then click on "Flash taskbar button X times" (where you can set the number of times it flashes).

The default value is 3 - or at least on my computer it is :)

Here's a picture to show you exactly what I mean:

Tweak UI Picture

share|improve this answer
    
Thanks, but it looks like there's no Tweak UI for XP x64 (only 32-bit and IA64). I suspect it modifies the same registry entry Molly mentioned, which is already set to 3. –  EMP Sep 18 '09 at 1:21
    
No, you linked to the 32-bit version, which is good, but I'm running XP x64 and there seems to be no TweakUI for that at all! –  EMP Sep 18 '09 at 1:35
    
Dude, softpedia.com/get/Tweak/System-Tweak/… works on 64-bit computers. It's what I used on my downstairs PC. –  Breakthrough Sep 18 '09 at 1:44
    
Ah, thanks, the second link does work for me. Unfortunately, that setting is already set to "3 times" as in your screenshot. –  EMP Sep 18 '09 at 2:01

Start > Run > type REGEDIT and click OK.

Navigate to the following key:

HKEY_CURRENT_USER\Control Panel\Desktop

Create or modify the DWORD value ForegroundFlashCount and set the value to 3.

share|improve this answer
    
Thanks, but it's already set to 3. :( –  EMP Sep 18 '09 at 1:18
1  
change it to 1 –  Molly7244 Sep 18 '09 at 1:44
    
Doesn't help - it still keeps blinking. –  EMP Sep 18 '09 at 4:04
    
Try zero? Would that work? –  Torben Gundtofte-Bruun Sep 18 '09 at 6:35
1  
zero keeps 'em flashing indefinetely. –  Molly7244 Sep 18 '09 at 9:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.