Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install Windows 7 Professional from USB 3.0 flashdrive, on a Thinkpad T61. The problem is, Thinkpads BIOS will not detect the flash drive as bootable medium, and won't allow to boot from it.

What I did:

Enabled USB BIOS Support in BIOS (it was on by default)

In startup menu, added USB HDD to boot order (it has '-' sign in front of it)

Created Windows 7 install media with UNetbootin, WinUSB (linux tool) dd and Grub4DOS.

As you can tell, currently, I only have access to Linux machine to make the flashdrive.

What happens:

The T61 BIOS shows '-USB HDD' in boot order menu. The '-' sign suggests that the plugged flash drive is currently not bootable. The same flashdrive (with the same Windows image on it) is booting without any problems on a Dell D430 and Lenovo Y550. Also, Ubuntu 12.04 install USB created with Unetbootin shows as bootable ('+' sign in BIOS boot order menu) and boots from the F12 boot menu.

Additional info

thinkwiki.org says that some Thinkpad BIOSes do not use MBR on flashdrives. It suggests using Extended-IPL boot loader, but the provided links are broken and there seems to be no mirrors.

Solution:

http://superuser.com/a/430186/54970

share|improve this question
    
Did you try this tool to make the flash drive?...microsoftstore.com/store/msstore/html/… –  Moab May 30 '12 at 17:33
    
No, since I had no access to a Windows machine, I did not. –  Halik May 30 '12 at 21:28

3 Answers 3

up vote 3 down vote accepted

This may be just a workaround, but the problem is specific enough, that a workaround solution is good enough:

As MrJackV suggested, I tried booting PLOP Linux and using its boot manager to boot my Windows flashdrive. It turned out that with PLOP flashdrive plugged in, and Windows 7 flashdrive, the BIOS could see both drives in the boot selection menu and allowed me to boot Windows 7 installer. Doing it again, but with Windows 7 flashdrive only, there are no flashdrives, same as before.

EDIT: In case someone encounters the following problem

This method caused unexpected problem - Windows 7 setup would not allow me to install the OS on the drive. The log files revealed, that the drive I tried to install it to wasn't the primary boot drive. Using tools provided with the setup utility, I created a primary, bootable partition on the internal drive, copied setup files and booted from it, with the internal drive being the only one plugged into the system.

share|improve this answer
    
Is the plop flashdrive USB 3.0? I seem to vaguely remember windows won't boot off those. Use a usb 2.0 drive –  Journeyman Geek May 29 '12 at 23:47
    
Yes it is, but it boots on other machines without problems. –  Halik May 30 '12 at 9:39
    
@JourneymanGeek Its not the 3.0 drive that is the problem, but it is the 3.0 port on the PC that causes some problems, HP recovery has issues with this also....h10025.www1.hp.com/ewfrf/wc/… –  Moab Jun 4 '12 at 4:10

I think you might have some luck by using PLOP (found here) and following the instructions for creating a bootable USB drive (from here). Since it is based on Linux you might have some luck booting it up. If that happens, plugging the plop drive out and plugging the windows one in will have 99.9% of making the pendrive boot properly (If that does not happen then I have no clue of what could be wrong). Please comment if you are encountering additional problems

share|improve this answer

I had a similar problem on a Thinkpad X200 when the USB drive was prepared with the MS tool. The laptop did not boot, just displayed a flashing cursor. The problem was that MS tool formats the USB drive as NTFS, which not all BIOSes recognize. When I prepared the USB drive manually, formatting it as FAT32 and then unpacking the Windows 7 ISO file there (instructions found on the internet), it finally booted and quickly installed Windows 7 on the HDD smoothly. The USB drive was prepared using a different Windows 7 laptop, because X200 had a wiped-out HDD, only NTFS-formatted - with Parted Magic.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.