Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have downloaded the FreeBSD 9.0 for i836 but during boot/installation I get the following message:

run_interrupt_driven_hooks: still waiting after 60 seconds for xpt_config

I waited for 10 minutes and nothing changed. I have no idea how to fix this. I tried to run it on: Intel(R) Core(TM)2 Duo CPU T5450 @ 1.66GHz,2GB RAM.

Does anyone know why I am getting this error and how I can correct it?

share|improve this question

2 Answers 2

Which hardware are you using? Does it include IEEE1394 aka firewire?

I ask because there are known problems with some boards with have firewire enabled.

Note that XPT is not just firewire specific though. It is a driver provides a way for userland applications to issue certain CAM CCBs (SCSI commands) to the kernel. So it could be other stuff. But disabling firewire in the BIOS and then trying to boot is an easy test.

[Edit] Added link to open PR: http://www.freebsd.org/cgi/query-pr.cgi?pr=136327

share|improve this answer
    
Thanks for your reply. I don't know if it include IEEE1394. How do I see about firewire of my computer? and how to disable the firewire? –  Jack May 30 '12 at 4:34
    
Depending on your hardware the easiest way might be go into the BIOS and look for firewire. Alternative are reading the motherboard manual or looking though dmesg. –  Hennes May 30 '12 at 5:03
    
I have looked for "firewire" in BIOS,but not found anything.. the lspci command can help you to point me a way? –  Jack May 30 '12 at 5:12
    
I have tried this too as @Jonh mentioned: security.stackexchange.com/questions/4098/… –  Jack May 30 '12 at 5:12
    
All this is assuming that it the hardware has firewire. There might be another problem. FW seems to be the most common source of there errors (or at least the ones I have seen most). –  Hennes May 30 '12 at 5:57

Remove your PCI controllers and boot into FreeBSD OS and make the following entry in the /boot/loder.conf file

hw.pci.enable_msix=0
hw.pci.enable_msi=0

and try to boot with PCI controller.

share|improve this answer
    
Where is this file? do I need to compile the kernel by myself? –  Jack Oct 12 '13 at 13:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.