Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a Windows 7 (64-bit) machine as a build server and have encountered a strange problem.

One of my build steps is to apply a code signing certificate using a command like this:

signtool sign /v /sm /s my /n "Company" /t http://timestamp.verisign.com/scripts/timestamp.dll /d "Software Name" "installer.msi"

After starting up the machine, this command works time after time for a while... and then it returns the error:

SignTool Error: The specified timestamp server either could not be reached or returned an invalid response.

The problem cannot be resolved until the computer is rebooted. The problem is also specific to this particular machine.

Does anyone have any ideas?

Thanks, Alan

share|improve this question
    
Having exactly the same problem here. :( –  sean717 May 16 '13 at 18:45
1  
@sean717 Hopefully you have resolved this by now but if not, see my answer below. –  Alan Spark May 22 '13 at 8:04
    
My problem is solved. It turned out that the account under which tfs build runs has no access to Web. By enable it back. Everything works now. Yeah. This is embarrassing. –  sean717 Jun 4 '13 at 17:02

1 Answer 1

up vote 0 down vote accepted

In case it is helpful for anyone else, we "resolved" the problem by putting the signing code into a batch file and retrying the timestamp a few times if it fails.

signtool sign /a /v /sm /s  my /n "Company" /d "Software Name" "installer.msi"
signtool timestamp /t http://timestamp.verisign.com/scripts/timestamp.dll "Software Name" "installer.msi"
if ERRORLEVEL 0 GOTO END
signtool timestamp /t http://timestamp.verisign.com/scripts/timestamp.dll "Software Name" "installer.msi"
if ERRORLEVEL 0 GOTO END
signtool timestamp /t http://timestamp.verisign.com/scripts/timestamp.dll "Software Name" "installer.msi"
:END
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.