Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install git using sudo apt-get install git-core

But it fails with this error message:

Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
liberror-perl git-core patch
Install these packages without verification [y/N]? y
Err http://us.archive.ubuntu.com jaunty/main git-core 1:1.6.0.4-1ubuntu2
404 Not Found [IP: 91.189.92.183 80]
Err http://us.archive.ubuntu.com jaunty/main patch 2.5.9-5
404 Not Found [IP: 91.189.92.183 80]
Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/g/git-core/git-core_1.6.0.4-       1ubuntu2_amd64.deb  404 Not Found [IP: 91.189.92.183 80]
Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/p/patch/patch_2.5.9-  5_amd64.deb  404 Not Found [IP: 91.189.92.183 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

How can I resolve these apt-get errors or install GIT using a different method.

Note: I've used apt-get to pull other things, it's just failing with git.

share|improve this question

migrated from stackoverflow.com May 30 '12 at 15:40

This question came from our site for professional and enthusiast programmers.

2  
Jaunty is massively beyond unsupported. The archives you once installed from are no longer there. –  tripleee May 30 '12 at 15:27
add comment

2 Answers 2

Ubuntu ended support for Jaunty Jackalope (version 9.04) on 23 October 2010. The Ubuntu mirrors most likely no longer have the packages you're looking for.

You can find instructions on how to update an EOL Ubuntu product here: https://help.ubuntu.com/community/EOLUpgrades

share|improve this answer
    
Thanks for the reply. I see that now. I just started a position here and sortof have been just thrown all this info to the servers and saying here, fix these :P Appreciate the response. –  jamadri May 30 '12 at 16:19
    
If this is a production box, make sure you have a full backup before upgrading to the latest Ubuntu. Nothing should break but ... –  Jeremy W May 30 '12 at 18:26
add comment

If you don't want to upgrade your ubuntu, you can build git yourself. The problem with getting git from the standard package managers (and default resources) is that they lag the latest git version quite a bit in some cases.

Git is just a command without any hooks into the OS, so using and installing it outside of a package manager is just fine.

share|improve this answer
    
The op would probably benefit from directions on how to download and build git from source –  Jeremy W May 30 '12 at 18:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.