Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got Vista installed on a PC with a US keyboard layout and Japanese input (IME) installed.

On my work PC running XP I've got the same setup.

In XP, I can input in Japanese using the US keyboard layout.

In Vista, when Japanese input (IME) is on, it changes the keyboard layout to the default Japanese keyboard layout.

I've looked at both Vista and XP's settings for 'Text Services and Input Languages' and can see no difference, or where it could be changed.

How can I setup my Vista PC to use Japanese input (IME) using the US keyboard layout?

Current settings:

enter image description here

share|improve this question
    
Please fix you tagging -- it's "vista" not "visa" –  HD. Sep 18 '09 at 8:59

3 Answers 3

up vote 1 down vote accepted

i solved using this.

http://bluebluewave.wordpress.com/2009/08/19/japanese-input-with-azerty-in-windows-7/

now my IME follow the italian keyboard layout :D

share|improve this answer
    
This looks like the most promising so far, I'll check it out! –  monkut Nov 9 '09 at 5:39
    
I can't believe that something like this doesn't have a normal fix, I guess thats what we get from software made in the US. This worked for me too, thanks! My life just got a little better! –  monkut Nov 19 '09 at 18:26

Could you post a screenshot of the vista IME settings? I think I know what's wrong but I am not on a vista machine at the moment and need a visual since I don't setup the IME's that often.

EDIT: Try removing Japanese under keyboards and just leave Microsoft IME. I think that is your problem. In XP under keyboards I only have IME setup for mine and it lets me type using the standard romaji spelling style then spacebar to convert hiragana to kanji and etc.

share|improve this answer
    
Tried removing US under keyboards and leaving Microsoft IME, but the layout uses a standard japanese key board layout. –  monkut Sep 19 '09 at 16:29

I had the opposite problem a while back, a Japanese keyboard would only be recognized with a US English layout. This KB article fixed the problem for me, maybe it can work in reverse for you.
This also seems related.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.