Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am connecting to Windows server using PPP (for vpn), I establish connection but server does not respond me for my address requests:

*Mar 23 00:40:06.055: Vi1 MS-CHAP-V2: I CHALLENGE id 0 len 25 from "MSDC"
*Mar 23 00:40:06.063: Vi1 MS CHAP V2: Using hostname from interface CHAP
*Mar 23 00:40:06.063: Vi1 MS CHAP V2: Using password from interface CHAP
*Mar 23 00:40:06.067: Vi1 MS-CHAP-V2: O RESPONSE id 0 len 69 from "XXX"
*Mar 23 00:40:06.087: Vi1 PPP: I pkt type 0xC223, datagramsize 50 link[ppp]
*Mar 23 00:40:06.087: Vi1 MS-CHAP-V2: I SUCCESS id 0 len 46 msg is "S=XXX"
*Mar 23 00:40:06.087: Vi1 MS CHAP V2 No Password found for : XXX
*Mar 23 00:40:06.091: Vi1 MS CHAP V2 Check AuthenticatorResponse Success for : XXX
*Mar 23 00:40:06.091: Vi1 IPCP: O CONFREQ [Closed] id 1 len 20
*Mar 23 00:40:06.091: Vi1 IPCP:    VSO OUI 0x00000C kind 1 (0x000A00000C0100000000)
*Mar 23 00:40:06.091: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar 23 00:40:07.091: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
*Mar 23 00:40:07.091: Vi1 LCP: O ECHOREQ [Open] id 1 len 12 magic 0x194CAFCF
*Mar 23 00:40:07.103: Vi1 LCP-FS: I ECHOREP [Open] id 1 len 12 magic 0x361B62E5
*Mar 23 00:40:07.103: Vi1 LCP-FS: Received id 1, sent id 1, line up
*Mar 23 00:40:08.083: Vi1 IPCP: TIMEout: State REQsent
*Mar 23 00:40:08.083: Vi1 IPCP: O CONFREQ [REQsent] id 2 len 20
*Mar 23 00:40:08.083: Vi1 IPCP:    VSO OUI 0x00000C kind 1 (0x000A00000C0100000000)
*Mar 23 00:40:08.083: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar 23 00:40:10.099: Vi1 IPCP: TIMEout: State REQsent
*Mar 23 00:40:10.099: Vi1 IPCP: O CONFREQ [REQsent] id 3 len 20
*Mar 23 00:40:10.099: Vi1 IPCP:    VSO OUI 0x00000C kind 1 (0x000A00000C0100000000)
*Mar 23 00:40:10.099: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar 23 00:40:12.115: Vi1 IPCP: TIMEout: State REQsent
*Mar 23 00:40:12.115: Vi1 IPCP: O CONFREQ [REQsent] id 4 len 20
*Mar 23 00:40:12.115: Vi1 IPCP:    VSO OUI 0x00000C kind 1 (0x000A00000C0100000000)
*Mar 23 00:40:12.115: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar 23 00:40:12.211: Vi1 LCP: O ECHOREQ [Open] id 2 len 12 magic 0x194CAFCF
*Mar 23 00:40:12.219: Vi1 LCP-FS: I ECHOREP [Open] id 2 len 12 magic 0x361B62E5
*Mar 23 00:40:12.219: Vi1 LCP-FS: Received id 2, sent id 2, line up
*Mar 23 00:40:14.131: Vi1 IPCP: TIMEout: State REQsent
*Mar 23 00:40:14.131: Vi1 IPCP: O CONFREQ [REQsent] id 5 len 20
*Mar 23 00:40:14.131: Vi1 IPCP:    VSO OUI 0x00000C kind 1 (0x000A00000C0100000000)
*Mar 23 00:40:14.131: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar 23 00:40:16.147: Vi1 IPCP: TIMEout: State REQsent
*Mar 23 00:40:16.147: Vi1 IPCP: O CONFREQ [REQsent] id 6 len 20
*Mar 23 00:40:16.147: Vi1 IPCP:    VSO OUI 0x00000C kind 1 (0x000A00000C0100000000)
*Mar 23 00:40:16.147: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar 23 00:40:17.331: Vi1 LCP: O ECHOREQ [Open] id 3 len 12 magic 0x194CAFCF
*Mar 23 00:40:17.343: Vi1 LCP-FS: I ECHOREP [Open] id 3 len 12 magic 0x361B62E5
*Mar 23 00:40:17.343: Vi1 LCP-FS: Received id 3, sent id 3, line up

You see: My router asks for address, but only keepalives are on line.

But the same server works with windows client!!

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
vpdn enable
!
vpdn-group pptp
request-dialin
  protocol pptp
  pool-member 1
initiate-to ip XXXX
!
!
!
!
!
!
!
bridge irb
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
bridge-group 1
!
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string XXX
dialer persistent
dialer vpdn
dialer-group 1
keepalive 5 3
no cdp enable
ppp authentication ms-chap-v2 optional
ppp eap refuse
ppp chap hostname XXX
ppp chap password 0 XXX
ppp ipcp mask request
ppp ipcp ignore-map
ppp ipcp address accept
!
interface BVI1
mac-address XXX.XXX.XXX
ip address dhcp
!
ip classless
ip route 172.0.0.0 255.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
!
dialer-list 1 protocol ip permit
!
control-plane
!
bridge 1 protocol vlan-bridge
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end
share|improve this question
    
which version of windows server are you using? – Mike Pennington May 31 '12 at 10:03
    
I cant find "add comment" button:(( Mike Pennington, that is not my server (so I am not able to trace problem from the other end) but I am sure it is windows 2008 – user996142 May 31 '12 at 19:30

Fixed: MPPE was required by server. But why did PPP started IPCP phase before finishing encryption (which should be lcp)? Anyway, vpn works fine now.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .