Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I "double click" on an Excel file and another Excel file is open, the newly opened file automatically opens in the same application window as the previously opened Excel file. This isn't limited to just Excel, as I've seen Word do this as well. This poses a problem when wanting to compare documents side by side.

The current solution I have for this is to actually open another Excel or Word instance, and then open the file from within that application window itself. Is there a way to force Office to open a new instance of the application when double clicking on the file icons?

I'm currently using Office 2007 and Windows XP but I've seen this on Office 2010 and Windows Vista and 7. I'm looking for an overall solution if possible.

share|improve this question
1  
I believe this has been this way for several versions. Why launch and second instance when there is no reason. MS provides a way to do - see below. Calling Excel stupid probably hurts its feelings. –  uSlackr May 5 '11 at 16:53
    
Alternative: Stretch the window manually, then use Excel's "Arrange All" feature, under the View tab. –  Iszi May 5 '11 at 16:54
    
Office has at least with Word to compare to documents. What you are doing now is the way you "force" it to behave this way. –  Ramhound May 31 '12 at 16:17
    
dottech.org/26491/… This link has clear instructions with pictures to show you how to change the settings in Excel to force it to open each file in a different window. –  user277569 Nov 28 '13 at 1:43
    

10 Answers 10

up vote 7 down vote accepted

I have Office 2010 and the only app that does this for me is Excel.

A posting on PC Review, How to open vista excel in multiple windows versus 1 window? explains how to set this up:

  1. Use the File Association Settings
  2. You have to tell Excel not to use DDE to open the worksheet.
  3. Open Windows Explorer, Tools, Options, File Types
  4. Scroll down to XLS
  5. Select Advance Button
  6. Click on OPEN in the Actions window, Then Edit
  7. On the 2nd line for application used add "%1".
  8. Make sure to put the quotes around %1.
  9. Example ...\Excel.exe" /e "%1"
  10. Write down what you see in the DDE Section.
  11. You will need this information if you want to return to the original settings.
  12. Now DeSelect Use DDE

When you double click on any XLS file a separate instance of excel will run.

Another advantage is that you can open more than one XLS file with the same name

share|improve this answer
    
This works for XP and Office 2007. If this works on my Win 7 Office 2010 machine at home, I'll accept the answer. –  KronoS May 31 '12 at 17:25
2  
The File Types tab looks to have been removed from the folder options in Win7. From what I've read this must be done through the registry. –  Scott Felhofer May 31 '12 at 18:55
2  
This solution does not work for Windows-7. Do you have a way to solve this via the registry? –  KronoS Jun 18 '12 at 16:57

In my experience, if you open the second spreadsheet using File >> Open, it opens in the same program window.

If you open a second Excel instance from the Start menu or a desktop icon or such, then use File >> Open in that window, it opens in its own program window.

I agree that it's broken behavior and I know of no way to fix it except, perhaps, begging Microsoft to change it in some future release.

share|improve this answer

I have been using a small batch file to circumvent this problem with Excel and it works fine for me: every time I double click a document, it opens another instance of Excel.

  1. Using notepad create a batch file (e.g., "C:\Program Files\ExcelLauncher.bat") with following content:

    START "" "C:\Program Files\Microsoft Office\Office14\EXCEL.EXE" %1
    
    START "" "C:\Program Files\Microsoft Office\Office14\EXCEL.EXE" /x %1         (for Excel 2013)
    
  2. Instead of "Office14" write the folder name where your Excel is installed (it depends on the version of the Office). It can be "Office12" ili "Office11" for older versions.

  3. Try double clicking the batch file. If it is configured works correctly, it should open Excel.

  4. Set up Excel documents to be opened with this batch file (right click any Excel document -> Open with -> Choose default program -> find and select "ExcelLauncher.bat").

Warning - this might change the desktop icon for Excel documents. Use "Default Programs Editor(free)" and "BeCyHome(free)" to re-apply the correct Excel icon.

http://www.howtogeek.com/109347/extract-high-quality-icons-from-files-using-a-free-tool/ http://www.winhelponline.com/blog/default-programs-editor-change-file-type-icon-windows-7-vista/

enter image description here

Note that you need to make 2 separate batch files to have separate icons for .xls and .xlsx. Otherwise, only a single icon can be applied to both filetypes.

share|improve this answer

No need for any of that for Windows 7!

If you go to the Taskbar and hover over an existing Excel icon (that then brings up a little preview of your open spreadsheet) and right click to bring up the Excel menu and then left click on the "Microsoft Excel 2010 option" it will open up another instance of Excel and you won't need any batch file or setting changes!

share|improve this answer
1  
This is an added step actually because I then have to manually open the file I want using the "open". I wouldn't be able to double click on an excel file and it automatically open a new instance, which is the issue I was running into. –  KronoS Mar 6 at 14:31
    
I think this does the same thing as Shift+Click on the icon. –  Nattgew Oct 7 at 18:12

Solution tested on Windows 8 with Excel 2007

This is all linked to DDE which the application can be told to ignore

Open Excel, go to Excel Options Select Advanced tab on the left Scroll down to General Section near the bottom There is a check-box to allow Excel to ignore DDE

If you check this it will stop further opened spreadsheets from joining it.


share|improve this answer

Seems to be the default behavior for me -- I get a seperate process, even. Try launching excel directly without opening a file to see if you get a seperate process/instance and open your file with OfficeButton->Open.

share|improve this answer
    
I'm opening files from Sharepoint, it makes using File --> Open less of an option. –  MVCylon May 6 '11 at 12:29

You can see the simple method at this link, or use this solution:

Go To Control Panel->Folder Options->File Types
Choose XLS (or whatever extension you need to work this way)
Go to Advanced

Uncheck "browse in same window" in advanced window.

Then highlight Open
Click the Edit Button

Make sure in the Action box it says &Open

Make sure in the application used to perform action it says:
"C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE" "%1"

Check the box next to use DDE

Remove anything that is in DDE Message box and DDE Application Not Running box.

Make sure the application box says: EXCEL

And in the Topic box it says: System

share|improve this answer
2  
This will not work in Windows 7. They have removed or modified the advanced file type editing. AFAIK –  MVCylon May 6 '11 at 12:26
    
Please remove the non Windows 7 instructions and I'll accept your answer. The first link you provided worked perfectly. –  MVCylon May 6 '11 at 12:28
    
@Doug, I think those other instructions would work fine for Windows 7 also, though I'd always go for the simple solution. In fact, before posting this I verified (and changed them a little) them in Windows 7 (as far as where the settings were, I didn't actually hit the OK buttons). –  Lance Roberts May 6 '11 at 15:58

DotTech has a guide on how to accomplish this for all versions of Excel in Windows 7 by updating the registry.

  1. Modify the default key in HKEY_CLASSES_ROOT/Excel.Sheet.12/shell/Open/command by adding a "%1" to the end (should end .../e "%1").
  2. Rename the command key in HKEY_CLASSES_ROOT/Excel.Sheet.12/shell/Open/command to anything else.
  3. Rename the ddeexec folder in HKEY_CLASSES_ROOT/Excel.Sheet.12/shell/Open to anything else.

Repeat the above steps in HKEY_CLASSES_ROOT/Excel.Sheet.8

Note that this process has to be repeated with many Windows and all Excel/Office updates.

share|improve this answer

I had the same problem with opening files in Sharepoint. The (crude) method I use is:

  1. Open the first document in the standard way, by clicking the link in Sharepoint.
  2. Click on the Sharepoint dropdown for the second document and select Send To -> Email A Link.
  3. Open a second instance of Excel and use this link in File -> Open.
  4. Repeat as necessary.
share|improve this answer

Another solution I found, using Total Commander:

Fo to File>Internal Associations (Total Commander Only)...

Click Add, specify the file extension you wish to open with Excel in separate windows with, such as .xlsx, .csv and .xls. Then, in the new window that pops up, paste in the Open box the path to the Excel executable, adding "%1" at the end. Mine looks like "C:\Program Files\Microsoft Office\Office14\EXCEL.EXE" "%1".

That's it.

Note: Works with Excel 2010 and Windows 7 32 bit without the need of Admin rights.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.