Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Ubuntu 11.10 as a guest OS using VirtualBox 4.1.16 installed on Windows 7 Ultimate.

On my laptop I'd like to be able to run Ubuntu in full screen mode at 1600 x 900. I only have options within the virtual machine to select 4:3 display settings such as 1600 x 1200, 1440 x 1050 etc.

I have guest additions installed.

At the windows command prompt, I tried typing:

VBoxManage setextradata "Virtual Ubuntu Coursera ESSAAS" "CustomVideoMode1" "1600x900x16"

This didn't work, still no 1600 x 900 res available in Ubuntu.

I tried this having read the following section of the VirtualBox help (this also says something about a 'video mode hint feature' not sure what this means):

9.7. Advanced display configuration 9.7.1. Custom VESA resolutions Apart from the standard VESA resolutions, the VirtualBox VESA BIOS allows you to add up to 16 custom video modes which will be reported to the guest operating system. When using Windows guests with the VirtualBox Guest Additions, a custom graphics driver will be used instead of the fallback VESA solution so this information does not apply.

Additional video modes can be configured for each VM using the extra data facility. The extra data key is called CustomVideoMode with x being a number from 1 to 16. Please note that modes will be read from 1 until either the following number is not defined or 16 is reached. The following example adds a video mode that corresponds to the native display resolution of many notebook computers:

VBoxManage setextradata "VM name" "CustomVideoMode1" "1400x1050x16" The VESA mode IDs for custom video modes start at 0x160. In order to use the above defined custom video mode, the following command line has be supplied to Linux:

vga = 0x200 | 0x160 vga = 864 For guest operating systems with VirtualBox Guest Additions, a custom video mode can be set using the video mode hint feature.


UPDATE 02.06.12

I've just tried creating a new virtual machine using the same original disk image I had been given. This had Guest Additions v 4.1.6 installed and provided me with the 1600 x 900 full screen display I want. It's after I then install Guest Additions v 4.1.16 (the version included with my VirtualBox installation) that my only choices are 4:3 displays e.g. 1600 x 1200. Seems this is the cause.

share|improve this question
    
What monitor do you have that's 1600 x 900? 1440 x 900 is common. –  Some Free Mason May 31 '12 at 20:08
    
It's the screen on my Dell XPS LS702X laptop. –  Grokodile May 31 '12 at 20:13
    
What happens if you try Ctrl F for full screen mode? –  BJ292 May 31 '12 at 20:21
    
It works, I just have a non-ideal res such as 1600 x 1200 with 300 pixels off the bottom of my screen the best fit I can select is 1024 x 768 but this leaves me with quite a bit of black margin around the VM. –  Grokodile May 31 '12 at 20:25
    
@panamack - If guest additions are set up correctly you should be able to do Ctrl F and have Ubuntu fill the screen. In fact you should be able to drag the border of the virtual machine and it should resize as you drag. How did you install the guest additions? –  BJ292 May 31 '12 at 23:01

2 Answers 2

up vote 1 down vote accepted

So, this seems to be a known defect.

The workaround is to disable 3D Acceleration for the Virtual Machine under Settings >> Display >> Uncheck "Enable 3D Acceleration" on the Video Tab.

share|improve this answer

Install Guest Additions + give the virtual machine 48mb video memory + fullscreen(ctrl/command+F) = it works for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.