Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Ubuntu 12. I'm changing my MAC address with ifconfig wlan0 hw ether xx:xx:xx:xx:xx:xx, which works. However when I restart my connection, my computer resets the MAC address to my original MAC address. I'm guessing that this happens because something calls...

ifconfig wlan0 down
... do something before connecting
ifconfig wlan0 up
... connect to designated access point
  • I want my MAC address to be the same no matter how many times I disconnect and reconnect, whether to another network or the same one.

  • Also it would be nice to turn off the auto-connect feature for my network-manager without having to edit each individual connection.

  • Lastly I would like to know how to connect to a WiFi network through the terminal and not via the GUI network manager Ubuntu provides.

share|improve this question

migrated from May 31 '12 at 21:42

This question came from our site for professional and enthusiast programmers.

up vote 1 down vote accepted

I want my mac address to however be the same

Try: right-click on network manager applet, "Edit Connections ...", choose (or create) a connection, "Edit", type a value into "MAC Address" box. These instructions are from 10.04.

Lastly I would like to know how to connect to a wifi network through the terminal

Look at /etc/network/interfaces and the commands ifdown and ifup.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .