Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I log into Ubuntu, I am prompted every time to:

Enter Password for Default Keyring to Unlock

I want to avoid this step since I am the only person using this machine and I see no reason to have any password protection.

Is there an easy way to turn this off so I can turn the computer on and get to the desktop without having to enter any passwords, just as I do on my Windows machine?

share|improve this question

6 Answers 6

up vote 11 down vote accepted

This can happen if your machine is configured to auto-login. You can work your way around this by setting a blank password for the keyring manager. Follow this guide to do this. This allows anyone using the computer to access your passwords.

There are a few other cases where you get asked for the keyring password, which I'm not very clear about. However, this prompt is not raised for most configurations.

share|improve this answer
    
I think there are a few bugs in this part of Gnome, especially when you wake up from hibernation. However they are pretty hard to corner. –  Peltier Sep 18 '09 at 8:56
2  
It's worth noting that in some installs, it's no longer at System->Preferences, but at Applications->Accessories. Alternatively, you could just run the command seahorse from Alt+F2 or the terminal. –  Shane Sep 4 '10 at 22:49

Here's an easier, more secure way:

1) Right click your wireless (Network Manager) icon in the tray and click Edit Connections.

2) Click the Wireless tab, highlight your wireless connection, then click Edit.

3) At the bottom there is a checkbox called "Available to all users". Click it then click Apply to save your change.

It will ask for your password because it is a system-wide change, but that's it! You, or anyone else you make an account for can now log on and get the wireless connection without anyone having access to your (unencrypted) passwords.

Jim

CISSP, Security Professional, general Linux enthusiast

share|improve this answer
    
Thanks, you saved my day! –  Mike L. Aug 15 '10 at 18:25
    
+1 Much better answer! –  John in MD Dec 4 '10 at 3:12

This is slightly different in Ubuntu 11.10. I opened up seahorse and deleted the "Passwords: default" folder under the Passwords tab. Once I did this I saw no way to create a new "Passwords: default" folder.

So I went back to an application that wanted to store it's password in my keyring, I used Empathy for this. While re-logging into one of my accounts I was prompted with a dialog box that asked to enter my password for my chat account. I typed it in and hit "Remember password" checkbox.

I was then prompted by a second dialog, "New Keyring Password". Here's where it was saying that "An Application wants to create a new keyring called 'Default'. Choose the password you want to use for it." I left this password box blank, and just clicked OK.

password dialog

Finally I was presented with a 3rd dialog box asking me if I wanted to "Store passwords unencrypted?" Here I selected "Use Unsafe Storage".

unsafe storage dialog

share|improve this answer
    
note that if you're using Linux Mint ~14 the steps are similar but the GUI is a little different. You have to check View > Show Any to see the tabs with the different key rings. –  hangtwenty Aug 28 '13 at 18:47

These didn't work for me but found this (comment 11) that does.

https://bugs.launchpad.net/ubuntu/+source/vino/+bug/562423/comments/11

share|improve this answer

here is the way I avoid this trouble maker under CentOS 5.

1> run "gnome-keyring-manager" to delete all of keyrings, that only "session" left there. because it is not able to be deleted.

2> copy /etc/sysconfig/network-scripts/ifcdg-wmaster0 into /etc/sysconfig/network-scripts/ifcfg-wlan0

3> change line "TYPE=Ethernet" into "TYPE=Wireless" in file ifcfg-wlan0

4> by clicking: System | Administration | Network, "Network Cofiguration" GUI comes out.

5.1> by selecting: wlan0 as Device, click "Edit", click "Wireless Setings",
Mode: Managed, Network name(SSID): Specified: YOUR SSID, key: you WEP key.

5.2> by selecting: wlan0 as Device, click "Edit", click "General",
set the related items as normal NIC as you want.

6> after saving. the WIFI NIC can be allocated IP as normal NIC without login.

7> limitation: it seems only support WEP.

good lock

share|improve this answer

This worked for me

alt-f2 seahorse

(or just System - Preferences - Passwords and Encryption keys)

On passwords tab, right click and select delete

Close seahorse and open it again (there was a message stating that default keyring was not found

File - New - Password keyring: name: default

Leave it blank (no password)

Click "use unsafe storage"

that did the trick for me

share|improve this answer

protected by Diago Dec 21 '10 at 8:14

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.