Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am re-branding a website that has both English & Chinese Traditional text. When I am copying + pasting the Chinese text into notepad++, the characters gets displayed as question marks. I tried changing the language settings within notepad++ to Chinese, but it now displays as squashed rectangles. I also changed my keyboard language setting in Windows 7 to Chinese but it did not work.

This is what I see when I right-click in Chrome to copy the Chinese character: enter image description here

share|improve this question
I would love to know if this got solved. I'm copying/pasting Chinese characters from a Word document into Notepad++, and Notepad++ is the only one that renders the characters incorrectly. My browser, other text editors, etc, all work fine, and YES Global Font and UTF-8 without BOM is selected in Notepad++ – RCNeil Oct 9 '12 at 14:57
up vote 1 down vote accepted

This thread seemed to at least damper my problem:

How to display chinese characters on Notepad?

Apparently, even though Notepad++ is storing the characters correctly, they are not being displayed correctly.

You can use one of the newly supported fonts (ver.6) under Settings > Style Configurator > Font Style > Font Name , the ones at the top, that support Chinese character display. So long as the file is encoded UTF-8, it will display correctly either way, you just may have to see squares instead of the actual characters when editing.

share|improve this answer

Since you are using Notepad++, be sure to set the Encoding to UTF-8 when dealing with non-ANSI characters (e.g. Chinese).


Also, you can verify the encoding of the page you are working with, and set Notepad++'s encoding to match. If you are using Firefox, the encoding can be found in the Page Info popup accessed by clicking the webpage's favicon.

page info

If changing the encoding does not resolve the issue, it may be that Notepad++ is using a font that does not support all characters for that encoding. Change the font by going to Settings > Style Configurator and setting the Global Font to a Unicode or proper typeface. (I use DejaVu Sans Mono.)


global font

share|improve this answer
I looked at the encoding of the source and it is Big5, and not Unicode. I modified notepad++ to Big5, but I'm still getting squashed squares when I copy + paste. – icu222much Jun 1 '12 at 21:35
Which font are you using in Notepad++? See my updated answer. – iglvzx Jun 1 '12 at 22:02
My settings are the same as yours except I did not have 'enable global font' checked. With your settings, I now get a question mark instead of a squashed square. Could there be a problem with my browser as I only see squares under the copy selector (see my updated question). – icu222much Jun 1 '12 at 22:48
Moving coding from ansi to utf-8 in notepad++ solved it for me, thanks! – JP Hellemons Nov 20 '13 at 15:43

Chinese text can be copy/pasted normally in Windows 7. It sounds to me like you're using a program that isn't Unicode-aware. As an experiment I opened up a text file (using plain old Notepad) that contains Chinese in Windows 7, copied a line and pasted it into this message which is inside a virtual machine running XP with the east Asian fonts installed. It worked.

share|improve this answer
I tried doing that in Notepad but I still got squashed squares. When I right-click on a Chinese character in Chrome, it says 'Search Google for []' where [] = square. – icu222much Jun 1 '12 at 19:11
@icu222much - This confirms Loren's theory. – Ramhound Jun 1 '12 at 19:33
I looked at the encoding of the source and it is Big5. – icu222much Jun 1 '12 at 21:34

I tried changing fonts, encoding and other suggested stuff but couldn't resolve the issue.

Creating a new user account in my windows 7 resolved the issue for me, I thought I'd have to move all the data from that account to the newly created account.

But surprisingly, it fixed the issue in the previous account also, so I deleted the new account using the old one without any problem.

Give it a try, hope that helps someone having the same issue.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .