Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install an odbc driver for vPostgres (Vmware's version for postgres) on Ubuntu 11.10 (64-bit). I have downloaded the rpm file of the installer (64-bit) and when I try to install the rpm using:

rpm -ivh Vmware-vPostgres-client.rpm, it shows me this error:

error: Failed dependencies:
    libc.so.6()(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libc.so.6(GLIBC_2.2.5)(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libc.so.6(GLIBC_2.3)(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libc.so.6(GLIBC_2.3.3)(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libdl.so.2()(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libdl.so.2(GLIBC_2.2.5)(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libpthread.so.0()(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libresolv.so.2()(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64
    libresolv.so.2(GLIBC_2.2.5)(64bit) is needed by VMware-vPostgres-client-1.0.1.1145-532311.x86_64

Few things I have tried:

locate libpthread.so.0 returns:

/lib/i386-linux-gnu/libpthread.so.0

/lib/x86_64-linux-gnu/libpthread.so.0

/lib32/libpthread.so.0

I get similar locations for all other files: locate libc.so.6

/lib/i386-linux-gnu/libc.so.6

/lib/x86_64-linux-gnu/libc.so.6

/lib32/libc.so.6

and so on.

I tried creating symlinks using:

sudo ln -s lib/x86_64-linux-gnu/libc.so.6
 /lib64/libc.so.6

sudo ln -s lib/x86_64-linux-gnu/libc.so.6
 /lib/libc.so.6

sudo ln -s lib/x86_64-linux-gnu/libc.so.6
 libc.so.6

but none of them worked. I am not sure where exactly it is trying to search for this files.

ldd Vmware-vPostgres-client.rpm doesnt help much and returns 'not a dynamic executable' which is expected

I tried adding the path in the /etc/ld.so.conf file

include lib/x86_64-linux-gnu/libc.so.6

I also tried setting the LD_LIBRARY_PATH to the specified file but of no use.

ldd --version shows GLIBC 2.13

Can anyone help me out where exactly does it searches for the file?

share|improve this question
    
Uhh, are you trying to install an rpm on Ubuntu?? –  mgorven Jun 2 '12 at 3:02
    
yes................ –  Deepti Jain Jun 2 '12 at 12:18

2 Answers 2

Ubuntu uses the Debian packaging format, and so you cannot sensibly install RPMs on a Deb based distribution. While it is possible to install the rpm tool, the package dependencies don't integrate with those of Deb packages, and the contents of packages may not necessarily work either.

The best solution is to find a Deb package of the software you want, and the next best option is to build it into a Deb package yourself (which is a fair amount of work). If those are not possible, the last resort is to try using alien to convert the RPM into a Deb. You will still need to deal with the dependencies manually, and possible with changes done in package scripts.

share|improve this answer

"alien" works for me:

$ sudo apt-get install alien
$ sudo alien VMware-vPostgres-client-1.0.1.1145-532311.x86_64.rpm
vmware-vpostgres-client_1.0.1.1145-532312_amd64.deb generated
$ sudo dpkg -i vmware-vpostgres-client_1.0.1.1145-532312_amd64.deb
...
Unpacking vmware-vpostgres-client (from vmware-vpostgres-client_1.0.1.1145-532312_amd64.deb) ...
Setting up vmware-vpostgres-client (1.0.1.1145-532312) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.