Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have one Tplink ADSL ROUTER and when i enter username and password on setup page then everything works fine.

Now i have one more router Netgear router then when i enter same username and password then interworks ok for some 50% websites but for other 50% websites the page is not loaded and it hangs there.

In the sats bar it says

website found , waiting for reply

and it hnags there and no site is displayed.

I wonder which setting is different on these two routers.

The Tplink router i have bought is from local shop but netgear router is from different country. Can that make some difference

share|improve this question

2 Answers 2

up vote 0 down vote accepted

A DNS problem is unlikely, since the name can obviously be resolved. Use ping to verfiy that the hosts are available, but note that some hosts do not respond to ping. Cross-check that with your other router. Then check for too large MTU values on your client or accidentially disabled MSS clamping in the router. According to the manual there might be no a way to disable this, but there there is a MTU size option mentioned on page 5-3. Try reducing this value to 1492 or even lower like 1400 and see if it helps.

Background: An MTU of 1500 is too large for PPPoE (I assume you have to use it on your line) and if the server you connect to is behind a black hole (broken firewall setup), you will get no reply with that MTU. Read more on http://en.wikipedia.org/wiki/Path_MTU_Discovery about this issue.

You also might want to try if these sites can be reached from the router directly. Maybe there is a test function somewhere in the web interface.

share|improve this answer
    
Thank you buddy , reducing MTU to 1400 worked. Now can you please explain why that worked for some sites and not in others. Does that mean that those sites erver has some setting that was causing the problem –  user825904 Jun 2 '12 at 9:18
    
Yes, this problem is caused by broken firewall setups on the server side which are quite common. Without firewalls (or correct firewall setups) the path MTU discovery will work just fine. As stated in the Wikipedia article, enabling MSS clamping is basically a workaround that reduces the MTU to a safer value so a working path MTU discovery becomes unnecessary. You might want to raise the MTU value again to the highest still-working value (probably 1480 or higher) to maximizie throughput, but the impact will be neglible. –  Gurken Papst Jun 2 '12 at 10:36

This is most likely a DNS problem. Your web browser (or computer) is probably caching your old DNS server settings from the router that works, which is why some sites are accessible.

This is either caused by invalid DNS servers on your router, or more probably a DHCP problem, where the DNS settings issued in the DHCP lease are wrong.

I don't have sufficient information about the models of router you own, but I suggest investigating your DHCP and DNS settings.

share|improve this answer
    
DNS for both i am using are the google servers i.e 8.8.8.8 –  user825904 Jun 2 '12 at 6:04
    
Are you flushing the DNS settings on your computer when switching routers? Bear in mind too that some browsers will retain a DNS cache beyond the context of your network card, for about twenty minutes, under certain circumstances. –  user3463 Jun 2 '12 at 6:06
    
I tried that and i am trying on different computers as well but same problem. More over i have two different internet connection on two phone lines but when i use that router same problem happens on that router. I am itself studing fro CCNP but i wonder how can trouble shoot cases like this. –  user825904 Jun 2 '12 at 6:15
    
Have you checked that the firmware is up to date on the "not-working" router? Have you done a factory reset and tried again? –  user3463 Jun 2 '12 at 6:16
    
i have just upgraded the firmware and its same problem. That router was working fine few months back and it worked well in Australia for 4 years. My router is this support.netgear.com/app/products/model/a_id/2326/session/… –  user825904 Jun 2 '12 at 6:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.