Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The laptop is a recent Dell XPS 15z and the problem is as follows (reproducible about 90% of tries):

  • put laptop to sleep using either Start->Sleep or closing the lid
  • laptop goes to sleep after about 5 seconds, but instantly wakes again showing a black screen (touching the keyboard or moving the mouse shows the login screen one normally gets after wake)
  • login again, put laptop to sleep
  • latop stays in sleep mode

output of powercfg -lastwake after the first instant wake shows the audio controller is responsible. Why would that be, why only the first try, and how to fix this?

Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Device
    Instance Path: PCI\VEN_8086&DEV_1C20&SUBSYS_04461028&REV_05\3&11583659&0&D8
    Friendly Name:
    Description: High Definition Audio Controller
    Manufacturer: Microsoft
share|improve this question
2  
Nobody is going to answer you because you have 666 points... –  Xan Jun 2 '12 at 13:30
1  
See if there is a power management tab for that audio device in Device Manager, uncheck the box "allow this device to wake computer" –  Moab Jun 2 '12 at 14:42
    
@XanderLamkins nice one –  stijn Jun 2 '12 at 17:57
    
@Moab checked that already, no power management tab.. –  stijn Jun 2 '12 at 17:57
1  
Since you're using PowerCfg.exe already, did you try the - DEVICEDISABLEWAKE switch? –  Ƭᴇcʜιᴇ007 Jun 2 '12 at 20:11

2 Answers 2

up vote 2 down vote accepted
+100

You may want to consider updating your BIOS; I've seen other issues around the web where people have had similar "wake-once" issues like yours, and some of the posts indicated a BIOS update fixed it.

Dell has a BIOS update for your laptop that was released on March 27, so unless you got your computer less than two months ago it's quite likely you'll need this (and even if you did get it more recently, it wouldn't be a bad idea to try it).

http://www.dell.com/support/drivers/us/en/19/DriverDetails/DriverFileFormats?DriverId=7TT65&FileId=2910945453&productCode=xps-15z&urlProductCode=False

An audio driver update might not be a bad idea either; however, it seems Dell has only released one, so you may already be running this version.

http://www.dell.com/support/drivers/us/en/19/DriverDetails/DriverFileFormats?DriverId=0T0GT&FileId=2731103525&productCode=xps-15z&urlProductCode=False

share|improve this answer
1  
I think he's currently using the (generic) Microsoft Audio driver. Using the actual Realtek driver is highly recommended (at least by me :P). –  Oliver Salzburg Jun 8 '12 at 13:34
    
good catch, I got the laptop a week before that update so never installed it. Now I did, and out of 3 tries sleep attempts none failed. Promising. –  stijn Jun 8 '12 at 15:54
    
@OliverSalzburg what exactly would be better about the Realtek driver (apart from the software)? Would there be any noticable difference in raw quality? –  stijn Jun 8 '12 at 15:55
    
@stijn: I just had a few experiences where the Generic Microsoft driver was causing me trouble and it was fixed by installing the driver issued by the manufacturer. So, I would just recommend it from experience without any real reason. –  Oliver Salzburg Jun 8 '12 at 15:58
1  
MS drivers are meant to provide basic compatibility/functionality with the widest range of devices and variants; manufacturer-specific drivers are going to be more fine-tuned to the device. Especially in the case of laptops, the OEM (Dell, here) may have a slightly tweaked version of the hardware, and the OEM-issued drivers will most likely (but not always!) work the best and have fewest glitches. –  Doktor J Jun 8 '12 at 16:42

This is not a direct answer but a temporary workaround while you figure out a permanent solution:

  1. Write a batch file to disable/enable(toggle) audio driver.
  2. Using task scheduler, schedule this batch to run on computer sleep and wakeup events(get exact event IDs from event viewer).
share|improve this answer
    
+1 seems pretty clever; not sure if disabling the driver, which was part of the problem, would do any good though –  stijn Jun 12 '12 at 13:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.