Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a weird problem on my Windows 7 (x64) computer. I seem to cannot ping the Google Public DNS on one of its addresses (while the other works fine). The peculiar thing is that it fails with the General failure. error message which usually means that there is a problem with a network adapter/base connectivity and not a timeout as one would expect.

Using ping on Windows 7

I checked my routing tables for any anomalies and I even flushed them but the problem seems unrelated. All the other hosts I tried ping fine (either respond or timeout).

If I try to tracert or connect to the address via browser (yes, I know that it doesn't listen on port 80), it also fails instantaneously.

The reason I need to ping is that I commonly use it as a test of Internet conectivity due to it being rememberable. The problem occurs no matter where I connect to the Internet (it is a laptop computer). What could be the cause of this anomaly?

Note: I use native IPv6 connectivity.

share|improve this question
Assuming you've already tried a reboot... Does it work in Safe Mode with Networking? Do you have any anti-virus or "Internet security" software running? – Ƭᴇcʜιᴇ007 Jun 2 '12 at 19:17
No, I don't use any Internet security solutions and the problem does persist after rebooting (even in Safe Mode w/ Networking) – Tibor Jun 2 '12 at 19:26
Router's route tables perhaps? – Ƭᴇcʜιᴇ007 Jun 2 '12 at 19:27
Even if router's routing tables would be a problem, the ping would just timeout and not fail with General failure. – Tibor Jun 2 '12 at 19:27
tracert? see if it's a particular point along the chain it's failing, or directly on your computer? – SeanC Jun 2 '12 at 21:42

You can rule out your computer and your network if you ping this address "from the internet" using a service like DNS Tools:! On this site it also does not work. However it works from my local computer.

share|improve this answer

This can be caused by anti-virus and/or firewall software (e.g. McAfee, Kaspersky, Comodo).

If you only have the Windows 7 Firewall, try Network and Sharing -> Windows Firewall -> Restore Defaults

share|improve this answer

Have you checked out this question already? Why do I get "General Failure" when pinging host name on a Win 7 node on the network?

It suggests several solutions and points to a microsoft kb article.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .