Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Incognito Mode and today I have noticed that when I frequently visit some site in that mode browser logs it and even on not incognito mode it autofills in address bar making Incognito mode useless in my case.

Another fun thing is that the item is not in History so I can't manually remove it.

Couldn't find anything in Settings. Why is this happening?

BTW, instant search is disabled in my case.

Using the latest version to date.

Extensions installed

  • List item
  • Send to Google Docs
  • Google Translate
  • Eye Dropper
  • Delicious
  • Readabiliy
  • Pagespeed
share|improve this question
    
are you sure it's the browser and not some log on the site that does this? it could work of your IP address or something similar –  jackweirdy Jun 2 '12 at 20:18
    
how would site make browser to save it's address? (no bookmark either) –  bakytn Jun 2 '12 at 20:48
1  
I mean is it possible for the site to log your IP address and make suggestions. It's hard to give a specific answer without knowing what site(s) you're referring to. –  jackweirdy Jun 2 '12 at 20:49
    
but how can browser get those suggestions when I type in the address bar the first characters like the site is theinsider.com –  bakytn Jun 2 '12 at 20:53
1  
I'm much sure that this is due to Google search. As I type a site which I had never open in my browser and yeah its still showing the result for that. –  avirk Jun 3 '12 at 0:10
show 9 more comments

2 Answers

up vote 2 down vote accepted

It would appear you are running into the intended feature of the omnibox, it will give you auto-suggestions pulled from the internet as you type.

If you start typing 'superu' it may bring up superuser.com even if you have never been here before. this is not instant search as you mention you do not have enabled, instant search is an extension of this where it will actually load the best result, aka your feeling lucky, as you type. with instant search enabled it would already be loading superuser.com if you started typing it and it was the best result based on google magic.

Turning off Auto-Suggestions

  1. Clear your browsing history

  2. Click the Tools menu

  3. Select Options

  4. Click the Under the Hood tab and find the ''Privacy section

  5. Deselect the 'Use a suggestion service to help complete searches and URLs typed in the address bar' checkbox.

  6. Click Close.

referance: http://productforums.google.com/forum/#!msg/chrome/0DR-pLIVI5g/XuqF5qasts8J

share|improve this answer
    
I used the short URL's (bit.ly) how would it auto suggest? So it still tracks!. I marked this as Answered though. –  bakytn Apr 16 '13 at 6:56
add comment

The Incognito window in Google Chrome is meant to allow you to browse without storing your history or cookies that will connect your browser to your searches. If your primary problem is the auto-completion/auto-filling of addresses, just clear your history.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.