Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Fedora 17 with gnome-shell. I've installed Ubuntu fonts, and I'm running vim inside the gnome-terminal.

Quote often, I get the following problem:

Vim screenshot

What could be the problem? The problem happens during cursor movements (either by arrows or by the usual hjkl).

If I go to the other parts of the file, and get back to this section, these chars are gone. This also happens with other fonts (Monaco comes to mind). Also, this doesn't happen in GVIM with the same settings (font selection + size, color theme)

share|improve this question

1 Answer 1

What's the output of $ echo $TERM in GT and :echo $TERM in Vim?

I've had this issue in the past (with tmux) and worked around it by adding the following lines to my ~/.vimrc:

nnoremap <Esc>A <up>
nnoremap <Esc>B <down>
nnoremap <Esc>C <right>
nnoremap <Esc>D <left>
inoremap <Esc>A <up>
inoremap <Esc>B <down>
inoremap <Esc>C <right>
inoremap <Esc>D <left>
share|improve this answer
    
The output in both is 'screen'. –  Alex Jun 4 '12 at 14:15
    
I tried the suggested configuration, and it does make it happen less, but still not completely solved. –  Alex Jun 4 '12 at 14:18
    
Are you actually running screen? If not, I doubt that's the correct $TERM setting. –  Heptite Jun 4 '12 at 17:59
    
As I said, I'm running tmux. What would be the right TERM settings then? –  Alex Jun 5 '12 at 11:25
    
You didn't say anything about tmux. Try this in your .tux.conf: set -g default-terminal "screen-256color". –  romainl Jun 5 '12 at 11:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.