Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


My Dropbox context menu is missing in OS X Snow Leopard (10.6.8). While the Dropbox service runs normally, Finder doesn't show the icons and also doesn't give me the ability to browse files on the website or copy the public link.

What I've tried

  • Removed ~/.dropbox and ~/Dropbox/.dropbox.cache
  • Reinstalled (both 1.4.7 stable and 1.5.0 experimental), went through the setup again
  • Restarted Finder
  • Logged out and back in
  • Removed /Library/DropboxHelperTools entirely, upon which the installer required me to enter the password and recreated the folder
  • Manually run /Library/DropboxHelperTools/DropboxHelperInstaller, results in this console output (also with sudo):

    <failure> 22
  • I know now that Dropbox hacks the Finder to insert these icons and context menu items, based on the FinderLoadBundle architecture (similar to this), but manually running the executables inside FinderLoadBundle.tgz under » Contents » Resources doesn't do anything either.

All of these I've done over and over again, in random permutations.

I've made sure that

  • Dropbox appears in the Login Items under my Account (and I've never touched that)
  • Folder Actions Setup is enabled under Keyboard Shortcuts » Services.
  • Everything works fine on a newly created user account.

In any case, I can't get the icons or the menu to appear.

share|improve this question
No problem, hope someones comes along with a proper answer. – Hassan Jun 9 '12 at 22:27
If you create a new account on your Mac and log into that, can you get it working there? – Spiff Jun 10 '12 at 0:51
Unfortunately, yes, @Spiff. I have no idea what I did to Finder though that makes it refuse to add these icons. – slhck Jun 10 '12 at 7:08
up vote 5 down vote accepted

In this thread, the person reported that Context menu is shown upon restarting the computer. can you please try that?

of course after install/reinstall :-).

share|improve this answer
You know what? That actually worked. I have no idea what service could have been related to this that would not have been restarted with a simple login/logout. It seems I just got used to not having to restart my computer every now and then like I used to do with Windows. – slhck Jun 16 '12 at 16:01
ya, i was also forgetting that a restart may be needed for such cases but recently i've installed some WiMAX modem drives that also required me to reboot :(. however, nice to know that it worked for you. – HungryCoder Jun 16 '12 at 17:27

Common fix to missing contextual menus in 10.6.x: Confirm that the "Folder Actions Setup..." service is enabled in System Preferences.

System Preferences -> Keyboard -> Keyboard Shortcuts -> Services -> Files and Folders. Make sure "Folder Actions Setup..." is enabled. (Snow Leopard 10.6.8)


NOTE: This step was already attempted by the poster, as indicated in the poster's question. I'm including it anyway, since taking this initial first step is what instantly brought back my Dropbox contextual menu under 10.6.8. It could be a helpful first step for someone else missing their context menu, so I request my answer to be left in as a quick reference for future user queries (@moderator & users: no votes needed).

share|improve this answer

I had the same problem and found that if I quit and restarted the Dropbox application it would work again.

I found that sometimes I would reboot/log out and in and it would work, other times a reboot/log out wouldn't help.

share|improve this answer
I just restarted the app and it worked, my options came back in finder. – swt83 Sep 15 '14 at 16:42

Definitively, Dropbox was the problem. This work for my on Mac OSX Snow Leopard and Lion.

  1. Go to Preferences > Keyboard > Keyboard shortcuts
  2. Look for Services then Files and Folders
  3. Probably "Folder actions setup..." will be enable. Uncheck it, then close Preferences and force quit Finder
  4. To force quit Finder press Opt+Cmnd+Esc, select Finder then Relaunch
  5. Go again to Preferences and repeat steps 1 and 2, then check "Folder actions setup..." in order it be enable again.
  6. Close Preferences and Force quit Finder again.
share|improve this answer
Doesn't work any more on Mavericks to disable Dropbox ugly context menu:( Ho to disable it now? – Altaveron Nov 11 '13 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .