Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently purchased a gaming mouse from a company named SteelSeries, I am running Windows 7 (32 bit) and they do provide drivers for my system. I have installed everything as instructed (and as I have done many times before) but it seems that windows decides to use the generic mouse drivers (mouclass.sys and mouhid.sys) instead of the ones I provided, I have tried updating the drivers manually but Windows claims they are up to date, but still the gaming mouse is recognized only as a HID-compliant device and not by it's full name and not using any of the supplied drivers.

I have tried temporarily removing the Windows drivers but still they are copied again from some Windows backup I guess and used. Any suggestions?

share|improve this question
    
Try to uninstall drivers completely and re-install them again. –  avirk Jun 4 '12 at 13:01
    
perhaps you need to run a program first. I had problems with mouse scrolling before on Windows 7. It turned out that I had to run the Synaptics program first to be able to scroll. –  WikiWitz Jun 4 '12 at 14:26
    
I have tried re-installing the drivers several times but still the same effect occurs every time, I have tried running the added software but still nothing changed. I have contacted the company's support staff but still no response. –  Jeff Jun 4 '12 at 14:52
add comment

1 Answer 1

When you perform an automatic driver update, Windows will use the latest ones available.

It sounds like the drivers are older than Windows' generic ones. As a result, Windows is selecting the newer generic ones.

What you want to do is to perform a manual update.

  1. Click Update Drivers on the mouse
  2. Instead of automatic, select browse my computer
  3. Select let me pick
  4. Click have disk
  5. Select the folder where the drivers are stored
  6. Select your device
  7. Click [OK] / [Finish] / [Accept] / etc.

Note: if you enter the folder at step three instead of selecting let me pick Windows will see your drivers, but notice the timestamp is old and just use the ones.

enter image description here

enter image description here

enter image description here

share|improve this answer
    
Thanks, Tried this and it told me it could not find any drivers in that folder, though I am sure these are the drivers for this mouse (confirmed with their support staff), although I am running 32 bit I have tried disabling driver signing verification just to rule that one out but still, I'll try using an older version or something –  Jeff Jun 4 '12 at 21:53
    
There will be one or more .inf files in the driver directory or one of its subdirectories. If the one in the top directory does not work (it may even be just an autorun.inf file instead of a driver information file), then try specifying one of the subdirectories instead. –  Synetech Jun 4 '12 at 21:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.