Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi guys I'm currently developing using rails and for some reason bundle install is returning the following output

Error Bundler::HTTPError during request to dependency API
Fetching full source index from https://rubygems.org/
Could not reach https://rubygems.org/

I've discovered that pinging by domain name keeps returning an unknown host.

The browser is still resolving web pages just fine and I've managed to confirm that the problem is localized (i.e. the rubygems page isn't down). I'm completely lost so any help would be much appreciated. Thanks in advance!

share|improve this question
    
Is the browser and cli on the same machine, and are you running a proxy server? –  Paul Jun 4 '12 at 13:15
    
@Paul They're running on the same machine –  tjkoding Jun 4 '12 at 13:24
    
if you ping another host does it work? –  devius Jun 4 '12 at 14:01
    
Does the web browser have a proxy configured? –  grawity Jun 4 '12 at 14:31
    
@grawity the web browser doesn't have a proxy configured –  tjkoding Jun 5 '12 at 15:50

1 Answer 1

When you ping, you shouldn't add a slash after the domain. Thus:

Incorrect:

ping rubygems.org/

Correct:

ping rubygems.org
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.