Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm ussing Putty to connect via SSH and running VIM. Whenever I enter a greater than character '>' the bell sound rings.

I can disable the bell entirely in Putty but that's not ideal.

Can anyone suggest why the bell rings when entering this character and how to make it stop?

share|improve this question
1  
hu... what? That the bell rings when typing the '>' in insert mode?? does it happen only with the '>' character? –  leonbloy Jun 4 '12 at 17:40
    
The bell rings whenever the > character is typed in insert mode. Presumably there are other times that the bell rings in VIM although I can't think of what they are right now. But if I type something like this: <html><head> the bell would ring twice –  Hibiscus Jun 5 '12 at 16:17
add comment

3 Answers

up vote 1 down vote accepted

You may need to disable the bell in VIM


PuTTY is responding to a terminal bell signal sent from VIM. To disable it type the following while in VIM normal (not insert) mode (hit ESC several times to make sure).

:set vb t_vb=

This will disable the audible and visual bell entirely for VIM.

You can add it to ~/.vimrc to make it permanent.

share|improve this answer
    
But VIM normally beeps when you've press some incorrect key, or when wants to call to attention to something. The OP seems to get a beep for an unexpected scenario. –  leonbloy Jun 5 '12 at 16:32
add comment

Command for > in VIM:

> : Shift right (indent)

share|improve this answer
    
Yes, and if this happened in visual mode then maybe it would be because I couldn't indent or something like that. But this happens on insert mode. –  Hibiscus Jun 5 '12 at 16:18
add comment

I was just fighting with this problem myself. According to a thread I found on nabble, the beep is caused by showmatch being on and vim trying to find and jump to the opening < for the > you're typing.

This can either be fixed by setting noshowmatch, or adjusting matchpairs so that it doesn't match < and >

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.