Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I'm working on a script to use RoboCopy to copy a bunch of files, and log what it's copied.

It works reasonably well, except for the logfiles. They tend to look like this:

C:\Users\Tech\Documents\desktop.initechscan1.jpgtechscan2.jpgtechscan3.jpgtechscan4.jpgtechscan5.jpgwsus.jpgwsus2.jpgC:\Users\Tech\Documents\My Music\C:\Users\Tech\Documents\My Pictures\C:\Users\Tech\Documents\My Videos\C:\Users\Tech\Documents\My Digital Editions\

As you can see, the log seems to be missing all whitespace and separators between entries. Is there something I can do to fix this? It's kind of frustrating.

The commandline I'm using is this:

C:\Users\Tech\Desktop>Robocopy.exe C:\Users\Tech\Documents c:\Temp /e /l /b /xj /xf ntuser.* desktop.ini *.lnk /np /njh /log:migratedfiles.txt /v

I have the /l in there since I'm debugging, and it's the easiest way to keep from copying everything a million times.

share|improve this question

1 Answer 1

I was experiencing the same problem with Robocopy's log being all crammed into one line with very little readable info. What fixed it for me is something I can see in your code as well; you're running the Robocopy command from your Desktop. Try running it from say, your documents (move the bat file if you're using one, or change the directory in your command prompt if you're going straight from cmd)

I have no idea why, but for me this fixed the problem right up. As soon as I'd hit cd.. and moved from c:\users\ishan\desktop to cd:\users\ishan, robocopy showed a proper log again. I use a .bat file myself for the robocopy command, so I moved that one into my Documents, ran it from there, presto, problem solved.

Hope this helps your problem as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.