Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have developed a site using WAMP and it's working locally.

I want to give access to other users, and when I put the server online and put my IP to the browser it's working.

When I put the IP into browsers of other computers (on the same network or outside) the server doesn't react.

Any suggestions?

share|improve this question

5 Answers 5

Ok. So, to be clear....

When you are sitting at the computer that is running WAMP, and you put the EXTERNAL IP address in the browser, you can view the web server.

When you are sitting at a different computer on the same IP subnet (connected to the same router and/or switch) and you put the EXTERNAL IP address in the browser, you don't see the web server.

When you are sitting at a different computer that is NOT on the same IP subnet (not connected to the same router and/or switch) and you put the EXTERNAL IP address in the browser, you don't see the web server.

Have you forwarded port 80 in the router to the internal IP address of that computer? Does your ISP allow inbound access/traffic on port 80? How would you test this? Well, first, make sure your router doesn't have a firewall blocking inbound port 80 traffic. Make sure you properly forwarded port 80. Make sure your internal IP address is static (in the DHCP table). If you have done these things... then it might be an issue with port 80. You can test it by going into WAMP and changing the port used to... whatever... 8080. This is just for testing purposes anyway. Then, go back into the router, and everywhere you dealt with port 80, change it to 8080. Then try accessing the server.

share|improve this answer
    
First thing I thought was port forwarding. +1 –  Joe Taylor Aug 8 '12 at 18:07
    
I ran into this issue on Windows Server 2008 R2 and solved it by creating an "Inbound Rule" in my Firewall to allow connections to port 80. –  w5m Aug 30 '13 at 8:44

Maybe apache is only listening on loopback address 127.0.0.1. Check your config files for this. To bind apache to all available interfaces on port 80 set cfg to Listen 80

See http://httpd.apache.org/docs/2.0/bind.html

Also, you can temporarily turn off all security/firewall software while testing it. Or if you surely know how, then first check and configure firewalls. If your private network has routers there may be firewalls/custom routing preventing others to connect. See Bon Gart's answer for details.

share|improve this answer

Go to:

WAMP → alias → phpmyadmin.conf file...

There is an option called "Deny from all".

Change it to "Allow from all".

It should work perfectly.

share|improve this answer
2  
is this safe though? Or is the access that they get read only? –  cohen Aug 4 '12 at 13:16

goto wamp\alias and make modify following three files

  1. phpmyadmin.conf
  2. sqlbuddy.conf
  3. webgrind.conf

and replace

Order Deny,Allow
Deny from all
Allow from 127.0.0.1

with

Order Allow,Deny 
Allow from all
share|improve this answer

i solved the problem by disabling the firewall for port 80.

  1. Go to Search on right side of windows.
  2. search "firewall".
  3. open the "firewall with advanced".
  4. go to inbound rules.
  5. click on "new rule".
  6. select the "Port" option.
  7. click "next"
  8. select "TCP" option.
  9. select "Specific local ports:".
  10. type "80" in next text box
  11. click next.
  12. select the "Allow the connection".
  13. click "next".
  14. click "next".
  15. give the name "Port 80 Allow Rule".
  16. click "next".

Note: this is not a secure way. delete this newly created rule when you complete your work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.