Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After installing Win8 x64 RC, Metro apps worked correctly, but desktop OpenGL apps were slow and unresponsive. I installed the latest Win8 nVidia drivers, and the OpenGL apps started working correctly. At the same time, because of annoying permission messages, I changed the C:\ drive and all its files ownerships to my user, and gave it full permission.

I restarted my pc after installing the drivers, and now Metro apps only show the splash screen, then crash.

I tried installing other versions of the nVidia drivers, with the same result.

My GPU is a GeForce GTX275.

Is this a known problem with nVidia drivers? Or maybe changing the ownership of C:\ is the real problem?

Thank you.


More information (after looking in the event viewer)

I've managed to find the problem and the error in the Event Viewer. I still cannot solve it. Here's the information I found by opening the Mail app and letting it crash:

Log Name:      Microsoft-Windows-TWinUI/Operational
Source:        Microsoft-Windows-Immersive-Shell
Date:          07/06/2012 15.54.17
Event ID:      5961
Task Category: (5961)
Level:         Error
Keywords:      
User:          VEE-PC\Vittorio
Computer:      vee-pc
Description:
Activation of the app microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail for the Windows.Launch contract failed with error: The app didn't start..
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" />
    <EventID>5961</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>5961</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2012-06-07T13:54:17.472416600Z" />
    <EventRecordID>6524</EventRecordID>
    <Correlation />
    <Execution ProcessID="3008" ThreadID="6756" />
    <Channel>Microsoft-Windows-TWinUI/Operational</Channel>
    <Computer>vee-pc</Computer>
    <Security UserID="S-1-5-21-2753614643-3522538917-4071044258-1001" />
  </System>
  <EventData>
    <Data Name="AppId">microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail</Data>
    <Data Name="ContractId">Windows.Launch</Data>
    <Data Name="ErrorCode">-2144927141</Data>
  </EventData>
</Event>

Found other stuff, this is another error that appears when opening a Metro app:

Log Name:      Application
Source:        ESENT
Date:          07/06/2012 16.01.00
Event ID:      490
Task Category: General
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      vee-pc
Description:
svchost (1376) SRUJet: An attempt to open the file "C:\Windows\system32\SRU\SRU.log" for read / write access failed with system error 5 (0x00000005): "Access is denied. ".  The open file operation will fail with error -1032 (0xfffffbf8).
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ESENT" />
    <EventID Qualifiers="0">490</EventID>
    <Level>2</Level>
    <Task>1</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-06-07T14:01:00.000000000Z" />
    <EventRecordID>11854</EventRecordID>
    <Channel>Application</Channel>
    <Computer>vee-pc</Computer>
    <Security />
  </System>
  <EventData>
    <Data>svchost</Data>
    <Data>1376</Data>
    <Data>SRUJet: </Data>
    <Data>C:\Windows\system32\SRU\SRU.log</Data>
    <Data>-1032 (0xfffffbf8)</Data>
    <Data>5 (0x00000005)</Data>
    <Data>Access is denied. </Data>
  </EventData>
</Event>

After changing permissions again (adding Everyone and Creator Owner to System32), the "access denied to sru.log" error disappears, but this one appears in its place:

Log Name:      Application
Source:        Microsoft-Windows-Immersive-Shell
Date:          07/06/2012 16.16.34
Event ID:      2486
Task Category: (2414)
Level:         Error
Keywords:      (64),Process Lifetime Manager
User:          VEE-PC\Vittorio
Computer:      vee-pc
Description:
App microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail did not launch within its allotted time.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" />
    <EventID>2486</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>2414</Task>
    <Opcode>0</Opcode>
    <Keywords>0x2000000000000042</Keywords>
    <TimeCreated SystemTime="2012-06-07T14:16:34.616499600Z" />
    <EventRecordID>11916</EventRecordID>
    <Correlation />
    <Execution ProcessID="3008" ThreadID="6996" />
    <Channel>Application</Channel>
    <Computer>vee-pc</Computer>
    <Security UserID="S-1-5-21-2753614643-3522538917-4071044258-1001" />
  </System>
  <EventData>
    <Data Name="ApplicationId">microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail</Data>
  </EventData>
</Event>

Now I'm stuck. It tells me "Activation of app microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail failed with error: The app didn't start. See the Microsoft-Windows-TWinUI/Operational log for additional information." but I can't find the Microsoft-Windows-TWinUI/Operational log.

I'm starting a bounty.


I found the TWinUI/Operational log. It only tells me:

Log Name:      Microsoft-Windows-TWinUI/Operational
Source:        Microsoft-Windows-Immersive-Shell
Date:          07/06/2012 16.28.57
Event ID:      5961
Task Category: (5961)
Level:         Error
Keywords:      
User:          VEE-PC\Vittorio
Computer:      vee-pc
Description:
Activation of the app microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail for the Windows.BackgroundTasks contract failed with error: The app didn't start..
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" />
    <EventID>5961</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>5961</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2012-06-07T14:28:57.238140800Z" />
    <EventRecordID>6536</EventRecordID>
    <Correlation />
    <Execution ProcessID="3008" ThreadID="2624" />
    <Channel>Microsoft-Windows-TWinUI/Operational</Channel>
    <Computer>vee-pc</Computer>
    <Security UserID="S-1-5-21-2753614643-3522538917-4071044258-1001" />
  </System>
  <EventData>
    <Data Name="AppId">microsoft.windowscommunicationsapps_8wekyb3d8bbwe!Microsoft.WindowsLive.Mail</Data>
    <Data Name="ContractId">Windows.BackgroundTasks</Data>
    <Data Name="ErrorCode">-2144927141</Data>
  </EventData>
</Event>

I need to go deeper. I found a forum thread that told me to look for "DCOM" errors. I found this one related to the app crash

"The server Microsoft.WindowsLive.Mail.wwa did not register with DCOM within the required timeout."

Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          07/06/2012 16.46.45
Event ID:      10010
Task Category: None
Level:         Error
Keywords:      Classic
User:          VEE-PC\Vittorio
Computer:      vee-pc
Description:
The server Microsoft.WindowsLive.Mail.wwa did not register with DCOM within the required timeout.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="0">10010</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2012-06-07T14:46:45.586943800Z" />
    <EventRecordID>2763</EventRecordID>
    <Correlation />
    <Execution ProcessID="804" ThreadID="2364" />
    <Channel>System</Channel>
    <Computer>vee-pc</Computer>
    <Security UserID="S-1-5-21-2753614643-3522538917-4071044258-1001" />
  </System>
  <EventData>
    <Data Name="param1">Microsoft.WindowsLive.Mail.wwa</Data>
  </EventData>
</Event>
share|improve this question
    
The first step would be to do a checksum on the iso you downloaded. If you downloaded it with something else than IE, there's a chance it's corrupt. –  Derethus Jun 7 '12 at 15:36
    
Checksum is fine. Also, Metro apps worked properly before I messed with permissions. –  Vittorio Romeo Jun 7 '12 at 15:45
    
Are you using Avast? –  pratnala Nov 2 '12 at 8:50
2  
Instead of changing permissions, I would recommend running sfc /scannow in an elevated command prompt to check for any corrupted system files –  pratnala Nov 2 '12 at 8:50

9 Answers 9

up vote 7 down vote accepted

I fixed it myself!

I added "ALL APPLICATION PACKAGES" to the C:\ security options, and gave it full control. Now Metro apps work fine. :D

https://dl.dropbox.com/u/3724424/fix.png

share|improve this answer
10  
What sort of security implications does this have? –  Feckmore Sep 6 '12 at 20:46
    
@Traples I have no idea. I don't use my computer with other accounts/in a local network so I don't think it will be a problem. –  Vittorio Romeo Sep 14 '12 at 15:45
2  
There's more to permissions than other user accounts and local network accounts. Different pieces of Windows run under different accounts with different permissions. You've just given every Application Package permissions to everything on your C drive. Aside from virus/security issues, what if a poorly written packages behaves differently because sloppy code was relying on permissions to keep them in check? What if a package cleans up after itself with a lazy, recursive delete command, that now deletes more than it should? –  Tanner Dec 26 '12 at 21:06
1  
Because of the security implications I strongly suggest to use the approach @Kory Sarnelli described below (that is to only modify the permissions of the path %USERPROFILE%\AppData\Local\Microsoft\Windows\WER –  tobsen Jan 5 '13 at 13:27

OK, it took me forever to solve this problem so hopefully this helps someone. I had changed permissions on my user folder (like I always do) to only allow my user and SYSTEM. Unfortunately this broke some Metro/Modern apps including Weather, News, Finance, Netflix, etc.

The only permissions that 'ALL_APPLICATION_PACKAGES' needs in order for all Metro/Modern apps to work are:

  1. File - %USERPROFILE%\AppData\Local\Temporary Internet Files\counters.dat - Read & Execute, Read - (You'll need to uncheck 'Hide protected operating system files' in Folder Options to see the Temporary Internet Files folder)

(if you cannot find in the above location try %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary Internet Files\counters.dat)

  1. Folder - %USERPROFILE%\AppData\Local\WER - Special: List folder/read data, Create folders/append data

(if you cannot find in the above location try %USERPROFILE%\AppData\Local\Microsoft\Windows\WER)

It does not need full access to your C: drive or even access to the Packages folder as previous answers suggested.

You can either reboot after making the above permission changes or kill the appropriate processes.

share|improve this answer
    
Hmm, I don't see these. Even with the hide protected setting turned off. –  paulwhit Nov 20 '12 at 4:54
1  
On my vanilla Windows 8 Pro only the folder %USERPROFILE%\AppData\Local\Microsoft\Windows\WERis there. I can confirm that the special permissions for ALL_APPLICATION_PACKAGES are indeed "List folder/read data" and "Create folders/append data" –  tobsen Jan 5 '13 at 13:25
    
Note that to do this you should be logged in as a different administrator account; otherwise you will not see the "counters.dat" file in Temporary Internet Files folder. –  Achal Dave Jan 25 '13 at 9:40
    
That file is a junction (Windows symlink): dir /a: <JUNCTION> Temporary Internet Files [C:\Users\Chloe\ AppData\Local\Microsoft\Windows\Temporary Internet Files] –  Chloe Mar 7 '13 at 22:06

In my case it was Avast. I had to disable all shields to get it working.

An update of Avast to the newest version fixed it!

share|improve this answer

The one thing I would add is that it is only necessary to add the "ALL APPLICATION PACKAGES" role to the "Packages" directory in the Local\AppData directory of the current user (e.g. C:\Users\Vee\AppData\Local\Packages). This way, you don't run the risk of giving the keys to the kingdom to an ill-behaved Windows app.

share|improve this answer
    
ALL APPLICATION PACKAGES does not have any permissions on the "Packages" directory when I installed windows 8. Are you sure it is the right one? –  joon Dec 22 '12 at 20:22

This Question is showing up high in Google, so here's what worked for me, without having to give permissions to whole system drive.

As mentioned by Pratyush Nalam run the command sfc /scannow in an elevated command prompt. Next run a chkdsk c: /f, say y when ased if you wan to schedule and then restart.

These command combined will fix many issues with permissions and corrupt system files.

share|improve this answer
    
This is the one that worked for me. Thanks! –  ismail May 20 at 18:06

I know this is a bit old, but I recently ran in to this same problem.

My ultimate resolution was to delete the SRUDB.DAT file and let windows recreate it. My problems went away entirely after this was performed.

share|improve this answer
    
No such file! Comments must be at least 15 characters in length. –  Chloe Mar 7 '13 at 22:24
    
how did u delete this file ..? is that safe ..? This file is always in use –  Shashwat Tripathi Sep 25 '13 at 15:33

If all the other ideas don't work, try this: I have my users folder on a D drive HDD, and my C drive is SSD, so if you don't have a SSD use C:

Add the All_Application_Packages userID to this folder:

d:\Users\Brent\AppData\Local\Packages

And give it ALL but FULL control, which is read, list, create, write, etc. This is the trick that made all my Apps come back.

Do not add this userID to your C:\ or Windowy folders, as you are just asking for trouble from giving any app you download unrestricted access to your PC's contents.

share|improve this answer
    
Better find out exactly what is complaining and why. Just changing permissions willy-nilly will cause problems later on. –  vonbrand Jan 22 '13 at 10:49
    
@vonbrand, dude, there is no logging of this issue, the apps just don't open because they lose access to certain folders. In addition, it is not a willy-nilly change, its contained and thought through, as I am giving a very specific ACL change to a METRO APPs related folder that fixes this temporarily until MS can provide a fix for this common error. I'll add the disclaimer: Folks, do NOT make this change to your C:\ or \Windows !! –  Steelgate Jan 23 '13 at 17:38

For me the answer was adding full access for ALL_APPLICATION_PACKAGES to the folder

%USERPROFILE%\AppData\Local\Packages

share|improve this answer

I have the same issue despite I have a fresh install since I just bought a new computer with Windows 8 pre-installed and it can't be that I have to refresh the installation again.

I checked all standard hints I found but everything was fine. Actually only the advanced apps like games or calculator didn't work but the simple apps like weather or maps worked.

I learned that the Metro apps have special access restrictions on Deskop PCs (x86) only. This is why tablet PCs or Smartphones don't experience this issue.

Finally only this hint worked for me:

add "ALL APPLICATION PACKAGES" to the C:\ security options and give it full control

However, it can't be that Metro apps have full control on system root "C:\" because this would open up a large security hole and thus I reverted this change and started checking on subfolders.

Fortunately one of the first subfolders I checked was "C:\Windows" and Bingo!

After I have added only "Read & Execute, List Folder Contents, Read" rights for the group "ALL APPLICATION PACKAGES" to the Windows root folder "C:\Windows" (same as %windir%) all Metro apps worked perfectly!

This security change is completely uncritical as actually everbody has such rights on the Windows root folder.

Btw somewhere on the MS web it says that these rights have to be set on "C:\Windows\system32" only (which is true as it was set with me) but it is not sufficient. It has to be the whole Windows root folder (which was not set with me initially).

I hope this helps all who were also almost there with Metro apps :-)

share|improve this answer

protected by Community Feb 15 '13 at 11:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.