Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I switch from Intel onboard grpahics to Nvidia Dedicated GPU?

When I go to windows screen resolution I see intel. I cant change it.

I go to Device Manager, I see both Adapters are there and Nvidia is known.I disabled intel, I didnt see any option to set one as primary so I disabled intel, black screen!Reboot and re-enable intel.

I right click on the desktop, choose "Nvidia Control Panel" and on 3D options I chose the desired game I want to play, High performance Nvidia, but it didnt switch when I started the game.

Then I made preferred GPU in the global settings High performance Nvidia for everything it still didnt change.I understand to save the battery etc. there is a switch option between these two but I dont see this switch when it is necessary, I cant also switch manually?Is there a manual switch FN key?I looked but couldnt find.

Why I want to do this?

1) Better game peformance.

2) I want to play an old game from 2002(Diablo 2 LOD), when I start the game there are black bars on the sides, so screen becomes just smaller which I dislike!I heard this is intel's specification to center the display.But instead I would like to scale or expand it to fit widescreen(fullscreen).Which should be possible with Nvidia.

My Notebook Specs: Fujitsu Lifebook AH531, Win7 , 64 bit, i5, intel HD graphics onboard, Nvidia GT 525.

I didnt install Nvidia later, it was always installed and ready from the moment I turned on the computer first time.

How I determined that the cards werent switched when I am playing the game: with the windows key I exited from the game, then looked at screen resolutions menu, still saw intel, also the game was still with black bars.I know intel GPU should enough for Diablo 2 but I am interested in this answer for further games, I dont always play Diablo, what if I install an up to date game for example?Then Intel will not be sufficient.I would like to learn the switch option.

share|improve this question
    
Nvidia was always there, or you just added it? If you just added it, did you switch the cable to the outputs on the GPU card opposed to the on-board output? –  Tim Jun 5 '12 at 15:06
    
What laptop model do you have? How did you determine that your laptop doesn't switch to the nVidia card when playing a game? Because that's what it's supposed to do. As for Diablo 2, it's simply too old to have proper widescreen support; see here for more details and possible solutions. The Intel HD graphics should be more than sufficient for that game, though. –  Indrek Jun 5 '12 at 15:07
    
I updated the question with answers to your comments. –  Anarkie Jun 5 '12 at 15:16
    
Diablo 2 might not be enough to force your laptop to use the dedicated nVidia graphics card. And like I said, the black bars are there due to lack of widescreen support in the game. Simply switching to another graphics card isn't going to make them go away. Anyway, try running a more graphically demanding game, or a graphics benchmark like Unigine or 3DMark, and compare your results to the ones here. –  Indrek Jun 5 '12 at 15:48
    
D2 is not enough to force but I did force it by few mouse clicks ... I dont have more advanced games but I will try the 3D Mark –  Anarkie Jun 5 '12 at 16:02
add comment

2 Answers

Assuming your laptop uses the nVidia Optimus technology, try using the nVidia Optimus toolkit to select to force your game to start with the Nvidia GPU.

You should be able to set rules/profiles for which GPU to use by right clicking the application icon and choosing "run with graphics processor" (or something like that) or using the nVidia control panel.

Some more information about Optimus here: How to disable NVIDIA Optimus on a Dell XPS 15?

share|improve this answer
add comment

For those having problems running Diablo II (LOD) with Optimus, I have found that setting the 'Preferred graphics processor:' to 'Integrated graphics' in Manage 3D Settings of the nVidia Control Panel will allow the game to start. Another solution which works even better is to use the Glide Wrapper

Another tool to mention is nVidia Inspector. With it you can edit nVidia Control Panel profiles. Click on the profile (tools) icon and then in Profiles select the program you want to modify. In the settings, under Other, find Enable application for Optimus and change the settings to SHIM_RENDERING_MODE_ENABLE. Once you have done that you can go into the nVidia Control Panel and change the applications preferred graphics processor.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.