Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I inherited an old WinXP/Linux dual-boot machine from the stoneage. Because it has Linux, the regular boot process is replaced with the Fedora boot loader; I cannot, therefore, press F8 strategically to tell my PC to boot from CD.

Even if I could, it's a moot point; the CDR doesn't seem to recognize any CDs. To make things worse, there's no option to network boot.

The original user is probably long gone; I don't know the password for any of the Administrator group users. I can login using my corp account, but that's unprivileged on this machine.

Since I'm not an admin, I can't do crazy things, like looking at boot.ini. Or deleting files. I only have 500MB free on my C drive. I'm pretty sure I can't boot from a USB, since I didn't see any settings for this in my BIOS.

How can I get admin access for my user?

Edit: Things I've tried:

  • Boot from CD (CD not recognized)
  • Launch CD from XP (CD not recognized)
  • Install Daemon Tools Lite so I can install from an ISO -- don't have admin privileges
  • XP password recovery tool -- requires admin privileges
  • Adding an admin user -- no access to Control Panel > Users since I'm not an admin
  • Logging in as both the admin users on the system (trying some standard passwords)
  • Using Fedora to chntpw (the Fedora version installed is ancient -- 2.7)
share|improve this question
1  
Since you have a corporate/company/domain account on the system that works, why not get the company's IT administrator to unlock it with their credentials? Can you boot form USB? What have you tried already? –  Ƭᴇcʜιᴇ007 Jun 5 '12 at 15:46
    
Hmm, can the IT admin really do that? I will ask them. I don't know if I can boot from USB. I have tried booting from CD, running Windows setup from a CD (both of which didn't work -- disc not recognized) and trying to install Daemon Tools Lite so I can open up an ISO on a shared drive. –  ashes999 Jun 5 '12 at 15:53
    
I would use Kon-Boot (piotrbania.com/all/kon-boot) to by pass the security. But you would still have to get a working internal/external cdr or made into a bootable usb thumb drive. –  Logman Jun 5 '12 at 15:56
    
I am confused: "boot from CD" happens "in the BIOS" before any boot loaders. If you can't hit a button, then surely you can change the boot order in the BIOS to look to the CD first. (Your point about BIOS/CDROM not recognizing boot CDs notwithstanding) –  horatio Jun 5 '12 at 16:10
    
@ashes999 - the domain admins should be able to change the privilege levels of any user for any system. They should be able to give you local admin privs on the system, for instance. –  Michael Kohne Jun 5 '12 at 16:13

2 Answers 2

The best way is to get your adminstrator to fix it - most tools to change a password rely on being able to boot off a cd.In any case check if its ok, before you do anything

On the other hand, you should be able to, if you had access to the bios, to select the boot device from there, and maybe USB boot it. You might also be able to boot fedora into single user mode

This may vary depending on your version, but according to fedora documentation

On an x86 system using GRUB, use the following steps to boot into single-user mode:

  1. At the GRUB splash screen at boot time, press any key to enter the GRUB interactive menu.

  2. Select Fedora with the version of the kernel that you wish to boot and type a to append the line.

  3. Go to the end of the line and type single as a separate word (press the Spacebar and then type single). Press Enter to exit edit mode

This should log you into a root account on fedora where you can do stuff.

Hopefully if this is a new enough version you could then change the windows password with chntpw - which is the same tool used here in the nt offline password changer utilty, which should give you full access to windows.

share|improve this answer
    
How exactly do I run chntpw? I boot into some sort of non-GUI shell interface; it's Fedora 2.7, if that matters. –  ashes999 Jun 5 '12 at 16:13
    
oh dear. In theory you would install it. Or at the very least get access via a NTFS driver. Thats an INCREDIBLY old version of fedora however - FC2 EOLed in 2005 - and probably supports neither. You can probably change the root password on the fedora install (with the passwd command). Then it gets tricky - there's no NTFS support, nor will anything remotely recent run on it. I wonder if you could somehow chainload an ISO off the bootloader.. but that sounds like too much work –  Journeyman Geek Jun 5 '12 at 16:22
    
I had a sneaking feeling this was the case when I didn't recognize the Fedora startup screen. It is sadly a machine from the stoneage. Thanks for coming out. –  ashes999 Jun 5 '12 at 16:32
    
No problem, this was a fun question to answer, and its good to see you have a solution. Don't forget to self select your own answer when you can ;) –  Journeyman Geek Jun 6 '12 at 6:10
up vote 0 down vote accepted

I solved this by plugging in an external DVD drive via USB. Thankfully, my BIOS was recent enough to recognize it; I deleted all the old Windows/Linux partitions and installed Windows anew. Phew.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.