Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an NTFS formatted drive (from a previous windows installation) and it contains some symlinks (reparse points),

For some reason, I can't do anything with these symlinks: I can't go to where they link to, I can't even delete them.

I guess the reason has to be that the link contained C:\ as a part of it.

How can I deal with this issue?


To clarify, these links are junctions/reparse points.

For instance, I had C:\progs be a symlink to C:\Program Files

If I try to remove it, I get:

$ rm /media/disk/progs/ -rf
rm: cannot remove directory `/media/disk/progs': Operation not supported

I actually removed /media/disk/Program Files/ anyway.


My system is linux mint (ubuntu based)

share|improve this question
are the "links" named something like "foo.lnk" ? – akira Sep 20 '09 at 20:19
no, that would be a shortcut – hasen Sep 20 '09 at 20:30
Symlinks and reparse points aren't exactly the same thing. (NTFS symlinks work exactly as Unix ones.) – grawity Sep 21 '09 at 12:16
Yea, I just didn't want people to think that I'm an idiot who thinks shortcuts and symlinks are the same. – hasen Sep 21 '09 at 13:23
and i just wanted to clarify that you are not an idiot who thinks shortcuts are the same as symlinks. it's just not that common to create such reparse points in windows ... – akira Sep 23 '09 at 4:39
up vote 7 down vote accepted

As explained in the Questions & Answers of the NTFS-3G support section, deleting a Reparse Point is not fully supported by the NTFG-3G driver. You might have to install the Advanced NTFS-3G driver:

Why do I get an "Operation not supported" message when deleting a file?

The NTFS-3G 1.5012 driver has solved this issue, or you're trying to delete an NTFS Reparse Point which is not fully supported yet in Stable NTFS-3G, only in the Advanced NTFS-3G version of the driver.

I can't provide more specific guidance without more informations on your Linux distribution, version, etc.

share|improve this answer
LinuxMint 7, based on Ubuntu 9.04 – hasen Sep 21 '09 at 11:41
Awesome, I downloaded the "executable for knoppix", version, and it worked! I just extracted it somewhere and did what the README said. – hasen Sep 21 '09 at 11:50
I'm glad I could help. – Pascal Thivent Sep 21 '09 at 14:43

Try using ntfs3g. You may have to create a file /.NTFS-3G if you have symlinks to a different drive letter.

share|improve this answer
What exactly should I try? – hasen Sep 20 '09 at 19:18
If he's using a mainstream distro (Ubuntu, Fedora, SUSE...) then it has the NTFS-3G driver installed by default. – John T Sep 20 '09 at 20:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .