Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I will tell you the story behind the problem.

The OS needed to be re installed. It has 2 HDDs so I had to un-plug one to see which is which, to save as much data as possible. After unplugging the first one, it booted with the installation CD.

It wasn't the HDD I was looking for so I turned it off and unplugged the other one. After unplugging and turning on, right after booting test, the HDD was turned off and the only thing that was working was the CPU fan. I turned it off the switch on the power supply, holding the power button didn't do it.

Now it doesn't turn on anymore. I tried with another test power supply but the result was the same, it won't turn on. Any ideas?

share|improve this question

1 Answer 1

The odds are high you knocked a wire loose somewhere. Check everything, if you don't find anything unplug the power wires and plug them back in. (A plug can LOOK seated and yet not be.) Do the same with the wires from the case to the motherboard.

share|improve this answer
    
I tried this. Changed the power supply with another one, unplugged the power up button's wire and plugged a jumper instead with no success after turning the power supply on. Isn't it supposed to turn on? –  Andrew Jun 5 '12 at 16:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.