Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just bought a new netbook, Lenovo S110 with a starter Window 7, 32 bit Operating system. I wanted to wipe away Windows and go with Debian or Ubuntu.
I have successfully made my USB drive bootable with the Debian net install.

The problem is, my computer always hangs up at the start of the installation (with the latter shown on screen). Keyboard stopped responding , and USB was probably not reading (since it was not blinking anymore).

I know the bootable USB drive with Debian installer is working since installation works on other netbooks.

What should I do to install Linux on my netbook?

share|improve this question

4 Answers 4

Have you set usb on top of the boot order in the bios?

Not all installers work with all mother boards: try something else, like setting up the full debian cd (not the netinstall one) on the usb with unetbootin

share|improve this answer
    
I have done all. But still hangs up. –  Neigyl R. Noval Jun 5 '12 at 17:51

Its not much help, but some brands of USB sticks just don't work with some systems - you might want to try another USB stick just to see if it helps - Here's another example where i had issues .

You might also want to try running dban on the hard drive if possible just to make sure it isn't some wierdness with the OS.

share|improve this answer

Re-burn the linux image to your USB device using your software and try again.

If still no luck, try the pendrive linux software:

http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/

and burn your USB that way.

I have a Lenovo x200 and pendrive linux installed Debian with no problems.

Also, might sound stupid, but double check you're installing a 32bit image (or 64 if your CPU supports it).

share|improve this answer

I tried installing openSuse 12.1 (32 bit) on my Lenovo S110. Everything went well, the partitioning, hardware detection, etc. When it restarted to do the necessary configuration, there were numerous hardware conflicts. I am no expert, there were just too many codes. Grub works fine. I tried failsafe mode, and it works because failsafe loads with minimal drivers. I think at the moment, netbooks are not compatible with linux. I have just installed openSUSE 11.4. Graphics at minimum. Networkmanager cannot detect wireless card, but it can detect mobile broadband. Word of advice. Do not use a usb mouse while installing. System will look at the wrong media.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.