Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't know how to explain this other than to say that my computer seems to magically run out of free when it runs for a while.

The output of df -h . oh my home direction is below

/dev/mapper/vg_vmadiath--dev-lv_home   50G   47G     0 100% /home

When I run sudo du -cks * | sort -rn | head -11 on /home I get the following output. I got this from decreasing free space on fedora 12

32744344    total
32744328    vmadiath
16  lost+found

If I restart my system things seem to fix themselves and I'm left with about 20 or 25GB of free space.

I'm running XFCE with XMonad as my window manager under fedora 17. Programs I'm running include the XFCE terminal, grep, find, firefox, eclipse, libre-office writer, zsh, emacs.

Any help will be greatly appreciated. I'll gladly give you any other output you might need.

share|improve this question
So, now you know the problem is /home/vmadiath. So now repeat that command to figure out which directory inside /home/vmadiath is growing. – David Schwartz Jun 5 '12 at 23:31
Thats what I did when running the second command. As you can see, vmadiath is only 32GB, while the partition is already full. – Varun Madiath Jun 6 '12 at 4:53
Then it's probably deleted files. As root, while the disk space is in use, execute this command: lsof | grep deleted – David Schwartz Jun 6 '12 at 5:48
I'm not sure how, but this fixed itself once I upgraded to XFCE 4.10. Thanks for all your help. David if this ever happens again I'll be sure to run that command. – Varun Madiath Jun 10 '12 at 19:18
Hi David, the problem has reared it's ugly head again. I ran the command you mentioned, and it gave me the following output (I ran this as root). I've also put the output at crond 861 root 3uW REG 0,16 4 19499 /run/ (deleted) xfrun4 1355 vmadiath txt REG 253,1 120448 50920 /usr/bin/xfce4-appfinder.#prelink#.ZewGnk (deleted) – Varun Madiath Jun 13 '12 at 14:16
up vote 0 down vote accepted

This turned out to be caused by a bug in emacs 24.0.95 when opened in daemon mode. Emacs had written 38GB of log data to the .xsession-errors file, which was causing my disk space to disappear. If you run into this problem, just upgrade emacs. I ended up compilnig 24.1.1 from source.

To see if emacs is causing this, open the .xsession-errors file, and see if you see a lot of lines with the text

Back to top level.
share|improve this answer

Glad that you found the issue. Here's a link to a script that I put together to find big files. The .snapshot dir is a filter for how we do NFS around here, but doesn't hurt, so I left it in.


share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .