Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an aging (and ailing) laptop running xubuntu. Often it locks up and i have to hard-reboot it, which isn't the problem i'm asking about here (i accept it as part of using an old laptop). The problem is that when it starts up it launches a few command window apps, each with loads of tabs open, and a few nautilus windows, again with tabs, and some other stuff that i don't want.

In the systen preferences (Xfce 4 settings manager) there's a list of apps to autostart. But, nautilus and the terminal aren't in there. In the next tab, "Session", there's a list of open apps which it considers to be part of the current session. I assume this is what's driving the opening of the various windows on startup - it's trying to resurrect some old saved session.

I don't want Xfce to try to resurrect an old session, EVER. Can anyone tell me where to find the config to tell xubuntu to stop doing this?

My xubuntu version is

Xfce 4 Desktop Environment
version 4.6.1 (Xfce 4.6)

thanks, max

share|improve this question
add comment

1 Answer

  1. Open settings manager
  2. Select Session and Startup

Then select which apps you would like to auto start with the tick boxes. Just set it to as little or as much as you want.

EDIT: Unsure why its launching command line apps. Have a look to see what you have set in the auto start. Does it tell you what its launching in the terminals?

Bill

share|improve this answer
    
Thanks Bill - i just updated my question as you were writing your answer (sorry!). I don't think it's the startup list that's the issue. –  Max Williams Jun 6 '12 at 8:39
    
No bother. Thanks –  William Fleming Jun 6 '12 at 8:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.