Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How to disable taskbar item jump list, that pops up when dragging taskbar item towards the desktop?

share|improve this question
1  
Can you tell us why you'd want to do that? –  slhck Jun 6 '12 at 10:24
    
I'm not sure I even understand your question, let alone try to answer it. Can you provide more details about what exactly are you trying to do? –  Corporate Geek Jun 6 '12 at 11:44
2  
The point is that it is also opened on the left click, when you move the mouse up without releasing the button. And that sometimes happens, when I want just to switch to another task but do inaccurate click. I never use that menu for anything, so I want to disable it for more robust task switching –  Arend Sep 27 '13 at 6:17

4 Answers 4

This will allow you to disable the taskbar context menus for all users on the computer in Windows 7. These context menus are enabled by default in Windows 7.

  1. Save this inside a file named taskbar_context_menus_disabled.reg.

    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoTrayContextMenu"=dword:00000001
    
  2. Right click on the .reg file and click on Merge.

  3. Click on Run, Yes, Yes, and OK when prompted.

Note: If not needed anymore, you can delete the file.

share|improve this answer
1  
This does not disable the content menu of items in the task bar but just on an empty spot in the task bar. It certainly doesn't do anything for all users on the computer. –  Peter Hahndorf Jun 7 '12 at 7:41
up vote 1 down vote accepted

7+ Taskbar Tweaker can do that.

share|improve this answer
    
Specifically, drag_towards_desktop (in 7+ Taskbar Tweaker's Advanced Options list) needs to be set to 1 to disable the jump list. –  Josh Townzen Mar 5 at 0:20

I tried to increase drag'n'drop rectangle size (that is used to detect the start of a drag operation) but can't get the satisfying solution. Too large size makes drag'n'drop annoying itself, while a bit larger size is not enough to solve the problem. So, still searching for the solution.

In a case anybody wants to try tweaking drag'n'drop here is how to do it:

HKEY_CURRENT_USER\Control Panel\Desktop\DragHeight
HKEY_CURRENT_USER\Control Panel\Desktop\DragWidth

Default value is 4. You need to log off to apply the changes.

share|improve this answer

go to Control Panel change the category to small icons and then choose Taskbar And Start Menu.Then check Auto-Hide the taskbar

share|improve this answer
2  
This hides the taskbar, but not the context menu. –  Dennis Jun 6 '12 at 12:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.