Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My DNS address seem to be set to 8.8.8.8 (primary) and 8.8.4.4 (secondary). These are Google DNS addresses, right? How can I change this so that I get the DNS address from my ISP? I can't change this in Windows because the computer is connected to a D-Link router, and I can't find any option to change this in the router.

share|improve this question
    
Why is it set to Google DNS?... I don't get it. I don't recall doing this. Where do I find the option for this in the router? I would like to get the DNS from my ISP. –  sammyg Jun 6 '12 at 13:05
2  
Is there anything wrong with Google's DNS? I prefer it greatly over my ISP's –  Simon Sheehan Jun 6 '12 at 13:06
1  
Were your DNS settings assigned through DHCP? –  Oliver Salzburg Jun 6 '12 at 13:08
    
@SimonSheehan: There are always privacy concerns when using a Google service. –  Oliver Salzburg Jun 6 '12 at 13:08
    
@SimonSheehan I don't think there is anything wrong with the Google DNS but I just find it strange that it would be set to Google DNS and not my ISPs DNS. I want to check it out and see what's going on there. –  sammyg Jun 6 '12 at 13:11

1 Answer 1

up vote 2 down vote accepted

You need to go to your router settings, and modify it there. Your router's IP is likely 192.168.0.1

Once you get there, login using your d-link router's credentials, and then modify your DNS settings under the header "DNS." You may need to ask your ISP which DNS servers you should be using.

share|improve this answer
    
I go to 192.168.0.1 log in and go to Setup, Netwrok Settings, and there is no option for it. But when I go to Status I see these two IP numbers on the WAN side. –  sammyg Jun 6 '12 at 13:14
    
@Sammy What kind of modem do you have? Is it one of those funky router/modem combo ones? –  Simon Sheehan Jun 6 '12 at 13:16
    
There is no modem in the setup. No, it's a router only model. I tagged the question as DIR-825. –  sammyg Jun 6 '12 at 13:21
    
What ISP do you use? It's possible (not likely) they are using google dns for some reason. Also, I can't get to the dlink site right now, but I believe you need to look under the 'advanced' network menu for the DHCP options. –  jhayes Jun 6 '12 at 14:26
1  
Finally! I found it by going to 192.168.0.1 then Setup, then Internet and then the button Manual Internet Connection Setup. –  sammyg Jun 6 '12 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.