Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a very peculiar problem with a station on our network. The client pc is running Windows 7 Pro. What makes this problem interesting is that this client is the only node on the network that seems to be experiencing this proglem. When I try to ping a specific Win 08 server by host name, I get an IPv6 address and get General failure. But when I ping it's IPv4 address, it responds just fine.

My first thought would check the DNS server the name resolutions to see what would be going on, but the problem begs the quesion, why does the station get an IPv6 address back and fails as opposed to using the IPv4 settings (which are static btw). What gives? I am including a screen shot of trying the one specific server and failing while trying another server with success. All other nodes on the network don't have problems communicating with the server the one station is having issues with. Pingng: General Failure

share|improve this question
1  
probably firewall related. Can you disable that computers firewall to check? If this works, then maybe resetting defaults of the firewall might fix it... –  Logman Jun 6 '12 at 15:22
    
Firewall on the machine is disabled. –  hydroparadise Jun 6 '12 at 15:33
    
Is the "IPV6 Protocol" enabled under network settings on the target machine? –  Diogo Jun 6 '12 at 15:50
    
@Diogo Yes IPV6 is enabled. Other machines on the network that are IPv6 enabled get ping responses via IPv6. –  hydroparadise Jun 6 '12 at 16:02
    
Maybe you should set a static IPV6 address on target machine and test again, it could be happening due to a mask limitation, I mean, your sorce and target machines arent on the same IPV6 network. It is really weird, my next step would be installing a sniffer such as wireshark and debug each step of icmp ping request/responses... –  Diogo Jun 6 '12 at 16:07

8 Answers 8

I had a similar issue. I had to uninstall the AnyConnect mobility client.

I had a constant ping running and was getting the "general failure." to 8.8.8.8; as soon as the uninstall was halfway done I was back to being able to ping.

share|improve this answer

In my situation, I found peerblock caused this.

Some applications block http traffic, peerblock for example. These cause pings to fail via the "General Failure" error message.

The way I found the application causing this was to kill processes one by one and checking the pings. Eventually I killed peerblock in my case and my ping started working.

If your pings are failing only for a few sites it most likely Firewall, Antivirus or some other HTTP interception/blocking application like Peerblock, Charles, Wireshark... etc.

share|improve this answer
    
though peerblock might have caused the issue in your case its not the generic answer, try modifying your answer to me more explanatory so that its helpful to future users –  Shekhar Oct 28 '13 at 19:32
    
@Shakehar I have amended my answer to try an be a little more generic. –  Oliver Oct 30 '13 at 12:53

I would get this error after:

  1. Accessing a site.
  2. Connecting to my corporate VPN.
  3. Accessing the same site.

It didn't happen for all sites, just sites that we (the company) published. To fix it, I ran

ipconfig /flushdns
share|improve this answer
up vote 3 down vote accepted

Found out through reading a couple of other posts that IPv6 is not exactly disabled by unchecking the protocal in the network adapter settings. Also, there's prefix policies built into windows that favors IPv6 over IPv4.

Turns out Microsoft has some tools that help with choosing presedence or choosing to disable IPv6 altogether on their site. Still not sure why I got the General Failure message in the first place, but at least I was able to fix the precedence using the Microsoft Fix it 50410 on that page (Prefer IPv4 over IPv6 in prefix policies).

share|improve this answer

In my case, this actually propagated all the way down to the Cisco VPN client. It said that there was a network subsystem failure. It turns out that my wireless nic was getting an IP address and all, but when I tried to ping my router, it was giving me a General Failure.

I took a look at device manager, and there were a bunch of new Bluetooth items that did not have their drivers installed. That was odd, because I hadn't installed anything new. In fact, this is a laptop with built-in Bluetooth hardware.

I know that Bluetooth allows you to do PAN (personal area network), so I wondered if this was somehow taking precedence over my WiFi NIC. I disabled all of these items in device manager, and although no new drivers were installed for this 'presumably new hardware', this allowed me to begin pinging my router. I'm now using my laptop successfully to both get on the we and VPN.

share|improve this answer

I also ran into a similar issue. Namely, I was unable to ping or tracert www.google.com on a Windows 7 operating system and it threw a General Failure.

I did the following to trouble-shoot and resolve issue:

  1. Issue command ping -4 www.google.com. This explicitly pings using IPV4. Did not resolve issue.
  2. Issued same command from #1, but ping -6 . Explicitly ping with IPV6. Error stated that it could not find host www.google.com

  3. Issued same command with different target (within my network) without issue.

  4. Temporarily stopped firewall (AVAST) and was successfully able to ping/tracert to www.google.com.

  5. Opened Avast Internet Security, clicked firewall settings on left pane, clicked Settings button.

  6. Clicked System rules and then enable ICMP (Internet Control Message Protocol ) to allow outgoing ping and trace request. Resolved Issue

Concerned: I issued the above commands on same workstation a few weeks ago without issue. I'm not sure how that setting was changed.

share|improve this answer

Fixed one of these on win 8.1 by resetting TCP/IP and Winsock. For anyone who needs info on how, open ADMIN command prompt and run:

Windows Vista, 7, 8

netsh i i r r

netsh winsock reset

Then reboot.

Windows XP

netsh i i r r

netsh w r

Then reboot. Good luck!

share|improve this answer

It appears your computer has 6to4, an IPv6 transition/tunneling technology, enabled. Unfortunately 6to4 is very unreliable in practice and for many people it is completely broken.

It's a good idea to disable all of the transition technologies if you aren't actually using them, since they can all cause various problems such as this.

You can do so from an Administrator Command Prompt with the following:

netsh int ipv6 isatap set state disabled
netsh int ipv6 6to4 set state disabled
netsh interface teredo set state disable
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.