Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop connected to internet through a cable and through WiFi. I also have a Windows VPN connection configured. Because of the VPN server configuration, I have to connect to it using the local cable connection, and when I have wireless off it works correctly. But when I have both wireless and cable connections on, the VPN fails as it apparently try to use the wireless one.

Is there something I can change in my local configuration so the VPN prioritizes the local cable connection over the WiFi?

My current workaround is to disable WiFi, connect to the VPN and then re-enable WiFi.

share|improve this question

2 Answers 2

up vote 2 down vote accepted
+50

You can prioritize network connections by doing the following.

  1. Open up Network and Sharing center
  2. Click on Change adapter settings
  3. Hit ALT
  4. Go to the advanced menu
    enter image description here

  5. Now you can order your network connections. The more higher your network adapter is, the more Windows will prioritize it.
    LAN order

This image is from Windows XP but should look more or less the same in Windows 7.

share|improve this answer

In our company we solved the problem with this change in the adapter.

  1. Open Device Manager
  2. Open up Network Adapters and double-click your Wireless WLAN Adapter.
  3. Under the Advanced Tab, click VLAN Priority Support (or Priority and Vlan) and select Disable from the drop-down menu under Value:.
  4. Click OK and test again.
share|improve this answer
    
I don't have that option under advanced settings. The WiFi card that I am using is Intel WiFi Link 5100 AGN with latest drivers. –  Guillermo Vasconcelos Jun 11 '12 at 15:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.